1

I'm on Edge connection because I have a third party device which I love. It's pretty fast most of the time, but today I think something happened. Android (4.2) keeps telling me "Message Not Sent" whenever I try sending a text. I even whiped my phone and it's still happening.. Like I said, it's on Edge but most of the time it isn't that slow. Not like this, at least. Why do I keep getting that error message?

I open Dolphin Browser, goes straight to any URL I type in. Weird that texts specifically are acting strange. Quite slow, but at least it works. Texts don't.

  • "SMS Service Center" in text message app.is blank when I tap it. Any ideas? – Mike Wentworth Mar 29 '14 at 12:50
  • Awesome. Thanks a bunch. How do I mark your answer as "best"? – Mike Wentworth Mar 29 '14 at 22:41
  • 1
    There, since that did turn out to be the problem, I've made it into an answer. I didn't at first because it was a bit of a guess. – Dan Hulme Mar 29 '14 at 23:00
2

From your situation, the most likely cause is that the message centre is not set correctly. First, find out the correct setting from your carrier: it's probably on their website, or you can phone their support line and ask. Once you know the correct setting, find the message centre option in the settings for the stock SMS app, and set it correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.