I have a problem: Once I have an Apple Wireless Keyboard paired with our Nexus 10 running KitKat 4.4 (rooted), no keys work. It is the oddest thing. To pair it, I have to enter the code that shows up, which I do and press ENTER and the pop up goes away. But yet, not a single key works. It even shows as Paired in Bluetooth (i've unpaired and paired it about 50 times).

This is not a duplicate because I have something unique that I have not seen in the dozens and dozens of blog posts, fixes, complaints, links, forum posts etc that I've read related to bluetooth and Android Keyboard.

I have previously paired another Apple Wireless Keyboard, and while it did pair and work correctly, a few keys were damaged. So, we got a new Apple Wireless Keyboard, and it is not working at all.

Even more info: the new keyboard works 100% correctly on my Nexus 5 (root), Galaxy Nexus (CM10.2) and Samsung S4 (CM 10.3) as well as on our Nexus 7 FHD (OEM, non-rooted).

So, the keyboard works on other devices. And, I previously had a different bluetooth keyboard paired with this Nexus 10. Why won't they both talk?

I have even factory reset, and wiped the Internal Storage on the Nexus 10 - nothing.

And yes, I removed the batteries from the other keyboard. Wifi does not matter as I tried it both on and off.

Again, it does pair successfully. Entering the wrong PIN during the pairing process gives the correct error message, and entering the correct one is accepted when pressing ENTER. So, the input IS working.

Lastly, I've noticed that the "Hardware Input" section of the Settings -> Language & input area doesn't show on this Nexus 10 (again, before and after a factory reset and internal storage format). Nothing, nothing at all. This area shows up on my Nexus 5 (4.4) and Galaxy (4.2) when I pair the same keyboard, which allows me to type using the external keyboard with a few additional settings.

On the Nexus 10, while the keyboard is paired, all it does it show the touch keyboard popup when I tap on an input field. On the Nexus 5 and Galaxy Nexus, when I tap on an input with the same keyboard paired, the touch keyboard does not popup - indicating it knows to use the external keyboard that is paired.

  • "Paired" only means that the devices can connect to each other: the keyboard needs to be "Connected" before it will work.
    – Dan Hulme
    Mar 30, 2014 at 9:21
  • It is "connected", as reported by Android Bluetooth settings. I can take the batteries out of the keyboard, and it goes to disconnected. Putting batteries back in, reconnects it.
    – eduncan911
    Mar 30, 2014 at 14:39
  • Good. I thought I'd better check, since you said it shows as "Paired". It would be awful if the only problem were that you needed to click to connect to it.
    – Dan Hulme
    Mar 30, 2014 at 14:50
  • Perhaps this has something to do with Google's switch over from the BlueZ bluetooth stack to Bluedroid after Broadcom released the source code for the latter. I'm in the same exact situation (Nexus 10 + Apple Wireless Keyboard + Cyanogenmod 11) where the device will pair but typing on the keyboard produces no output. Google is aware of the problem (multiple bug reports have been filed) but appears to be in no hurry to release a fix. More info available here Apr 5, 2014 at 4:01
  • As I said before, I have a 2nd Apple Wireless Keyboard and it works perfectly fine! Except, that keyboard has a few broken keys. It pairs and connects to the 2nd one, but no keys work.
    – eduncan911
    Apr 5, 2014 at 4:49

1 Answer 1


After a very long ordeal, several trips to several different Apple stores and basic trial and errors, I have found the solution as I blogged here:


The situation is that Apple made 3 different bluetooth Apple Wireless Keyboards, noted by years: 2007, 2009 and 2011.

The issue is that the 2011 model, with its latest firmware updates, does not work with the Google Nexus 10. It must be a bluetooth hardware profile issue with the Google device itself, as the 2011 keyboard works flawlessly on all other Android 4.2, 4.4.3 and 4.4.4 devices that I have as well as an Apple iPod Touch 4th Gen.

Solution: Get the 2009 Apple Wireless Keyboard

As I stated in my post above, I have tested several 2009 and 2011 keyboards and have confirmed only the 2009 Apple Wireless Keyboard works with the Nexus 10.

To restate the original issue: the 2011 Apple Wireless Keyboard will pair, and even "connect" normally to the Nexus 10. But, the Nexus 10 will not recognize it as an input device - it is missing the "A" keyboard icon at the top-left corner of the top status bar which normally shows with other bluetooth keyboards, such as the 2009 version.

Also note that the firmware I tested of the 2009 model was version x50. I could not confirm if the latest firmware update for the 2009 model worked or not.

  • 1
    +1 -- it's great that you came back and posted an answer for what worked for you; thanks!!
    – Shokhet
    Jul 24, 2014 at 2:24
  • +1 After nearly 4 months of turmoil, I owed it to the community to let them know.
    – eduncan911
    Jul 24, 2014 at 2:28
  • :) ....though it's a shame that the problem couldn't be solved with the old hardware....take what you can get I guess.
    – Shokhet
    Jul 24, 2014 at 3:02
  • 1
    My 2009 Keyboard with the same firmware version doesn't pair with my Nexus 10 or my Nexus 7 (both 5.0.2). It'll pair with my Nexus 5 (5.0.1) as well as a couple Apple devices. Mar 3, 2015 at 16:56
  • Hey @JamesMoore: I think you commented on the blog post (phonebanshee?), and I replied there as well. In short, I had to reset the Nexus 10 to factory defaults sometimes to get the bluetooth items to show up after I paired/unpaired/paired/unpaired trying to get things to work.
    – eduncan911
    Mar 3, 2015 at 19:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .