5

My phone is HTC desire, Android 2.2.

It seems to connect to the VPN server while using WiFi, but the browser and other applications can't be access the Internet any more. The connection is disconnected after minutes automatically. However, the same VPN settings work well while using 3G.

Update: The router allows VPN connections -- My PC and a Milestone 2 can use the same VPN over the WiFi network.

Update 2: It doesn't work over all WiFi connection! My phone could access the Internet when connecting the same VPN over the WiFi network of my office. It looks like the VPN only doesn't work over the WiFi network of my home.

Update 3 - solution After updating my phone to HTC official desire 2.3.3 dev ROM, it works. So it looks like there is a bug fixed by Android or HTC rom in 2.3.3.

Does anyone know how to resolve or diagnose this issue?

  • @xavier_fakerat have you tried always on VPN? and disabling miui optimisations (or whatever it's called) in developer options? – SSS Mar 13 at 16:52
2

A complete article on VPN on HTC Desire is present on the HTC Europe portal. Hope this will help you out.

Connecting to a virtual private network (VPN) From your phone, you can add, set up, and manage virtual private networks (VPNs) that allow you to connect and access resources inside a secured local network, such as your corporate network.

Depending on the type of VPN you are using at work, you may be required to enter your login credentials and/or install security certificates before you can connect to your company’s local network. You can get this information from your network administrator.

Also, your phone must first establish a Wi-Fi or data connection before you can initiate a VPN connection. For information about setting up and using these connections on your phone, see Data connection and Wi-Fi.

Setting up secure credential storage

If your network administrator instructs you to download and install security certificates, you must first set up the phone’s secure credential storage.

  • From the Home screen, press MENU, tap Settings > Security, and then tap Set password.
  • Enter a new password for the credential storage (at least 8 characters without any spaces).
  • Scroll down and confirm the password, and then tap OK.
  • Select the Use secure credentials check box.

You can then download and install the certificates needed to access your local network Your network administrator can tell you how to do this.

Adding a VPN connection

  • From the Home screen, press MENU, tap Settings > Wireless & networks > VPN settings.
  • Tap Add VPN, and then tap the type of VPN you want to add.
  • Tap the VPN settings and set them up according to the security details you obtained from your network administrator.
  • Press MENU, and then tap Save.

The VPN is then added to the VPNs section of the VPN settings screen.

Connecting to a VPN

  • From the Home screen, press MENU, tap Settings > Wireless & networks > VPN settings.
  • In the VPNs section, tap the VPN that you want to connect to.
  • When prompted, enter your log in credentials, and then tap Connect.

When you are connected, the VPN connected icon appears in the notification area of the title bar.

You can then open the web browser to access resources such as intranet sites on your corporate network.

Disconnecting from a VPN

  • Press and hold the title bar, and then slide down your finger to open the Notifications panel.
  • Tap the VPN connection to return to the VPN settings screen, and then tap the VPN connection to disconnect from it.
  • When your phone has disconnected from the VPN, the VPN disconnected icon is displayed in the notification area of the title bar.
1
+50

After updating my phone to htc official desire 2.3.3 dev ROM, it works. So it looks like there is a bug fixed by Android or HTC rom in 2.3.3.

  • Perhaps, its a bug that can only be solved by upgrading/downgrading ROM since no other answer has clues, I will award your answer bounty for a good question and thorough research. Hopefully this bug will be resolved :) – xavier_fakerat Mar 15 at 17:12

protected by Community Mar 7 at 18:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.