I have a strange problem for about a week. I have 3 input languages enabled on my smartphone (EN, RU, DE). To switch between them, I usually could slide the space-bar of the on-screen keyboard to the left or to the right.

However, recently this function has suddenly disappeared. The triangles do not appear on the space bar. I've found a few other posts on the internet, and there the authors connect it to the 4.3 Android upgrade. I am not sure though. I thought I upgraded quite a while ago and everything was OK. But I may be wrong.

Interestingly, if I switch to the hand-writing mode by tapping the "T"-button to the left from the space bar, the triangles appear on the space bar and I can now switch the language.

Any ideas?

  • In my case it was Greenify menu in Accessibility – Ilan Sep 12 '15 at 11:04
up vote 7 down vote accepted

I had faced the same problem myself.

System settings > device > accessibility > services. Something in there is set to On. Switch it to off and you will be OK. I had the same problem because I had an application set to on. Instant fix!

  • 1
    Amazing! It's the new LastPass autofill feature. Who would have thought! I've switched it off, and now the language switching is back. Thanks a lot! Will notify LastPass. – texnic Mar 31 '14 at 13:26
  • Actually, you enabled it because it needed your permission but when you updated to Android 4.3 that permission was not necessary so it conflicted with your system. Cheers! – Intruder Mar 31 '14 at 13:28
  • Reported: forums.lastpass.com/viewtopic.php?f=14&t=126325 – texnic Apr 3 '14 at 11:12
  • 1
    Mine was because of Master clean to extend the battery life. I switched that off and it worked Note3 – Hawk Aug 12 '15 at 6:56

For Me the solution was similar but different. I had nothing under the accessibility options excepted "Talkback" turned off. I turned it on then off and VOILA! it brought back the arrows.

  • Amro Elfiky thank you very much I had the same problem and you helped me solve it, you are awesome :))))))))))) – user65297 Jul 1 '14 at 10:46

protected by Community Nov 1 '14 at 21:59

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.