Just to clarify, it's my first time trying to unlock and root my phone, so I'm not very knowledgeable in this matter.

I basically followed the steps to unlock the bootloader.

Everything worked perfectly, I reached the recovery, went on 'apply update from ADB'.

But then, when I enter in cmd,

adb sideload 'whatever the filename

it prints out the Android Debug Bridge instructions on cmd rather than transferring the zip file to my phone, and the phone keeps on asking "now send the package you want to apply to the device with adb sideload filename ".

N.B.: the phone is recognized by adb, even when I enter adb devices, it is recognized.

Any help would be appreciated.


adb sideload does not transfer the file to the sdcard permanently. To sideload correctly, you need to pick that option from the recovery first and then when the phone is waiting for the sideload type,

adb sideload <PACKAGE>

If you want to push the file to the phone's sdcard, you could try,

adb push <PACKAGE> /sdcard/

That should copy the file over to the sdcard. Keep in mind that there is no progress bar.

EDIT: Try the following to restart the adb server,

adb kill-server


adb start-server

Then check if the instructions work again.

  • 1
    Every phone has an sdcard partition. In nexus devices (I have a Nexus 4), the sdcard partition is emulated so the apps still think there is one. Give it a shot, it will probable work. – chromozonex Mar 31 '14 at 19:47
  • 1
    Can you check if you have USB debugging enabled and if possible post a screenshot of what adb devices reports. Also check my edit to restart the adb server. – chromozonex Mar 31 '14 at 20:12
  • 1
    ok, I used to do adb push <PACKAGE> /sdcard/ when in recovery mode, that is why I used to get error: closed, I tried the same instruction after I started the phone, it did transfer them, but now, how can I install the rom? – user2584376 Mar 31 '14 at 21:11
  • 1
    hmmm, could that be the problem? hence I have no custom one, I just unlocked the bootloader, I think it is – user2584376 Mar 31 '14 at 21:23
  • 1
    Is your bootloader unlocked? – chromozonex Mar 31 '14 at 21:24

To solve this you can do it like this:

  1. Create an empty zip file (and name it, for example "sideload").
  2. Install adb drivers (adb setup 1.4.2 for example) or MTKdroid tools.
  3. Open CMD (or open MTK droid tools and click on "adb terminal")
  4. Type adb sideload <the directory name of the empty zip file> ("sideload.zip" for example)

Like this: adb sideload C:/Users/User/Desktop/sideload.zip

  1. If you do all the steps well, and type that in de command prompt it will go back to recovery and be able to reboot the phone.

PS: That's the only solution that worked for me (with an HDC S6).

Not the answer you're looking for? Browse other questions tagged or ask your own question.