1

I have a galaxy s3 SGH-t999l which is the t Mobile G3 LTE version. I'm rooted using the root 66 MK4 stock recovery tar in odin. I'm running TWRP recovery as well.

The problem is that I cannot get wireless tethering/hotspot to work no matter what I try- here are the things I've already tried-

Wifi Tetherr Treve Mod - I've tried nearly every version of Wifi Tether as well, with nearly every possible setting. Tried setting it up with s3 profile, with galaxy nexus profile, etc. All this ever does is start with errors, tell me to check the log and then when I do tell me that there is no log file.

Native Hotspot mod - this is an odin tar that is supposed to work, but there's no version for my baseband (Mk4), just MK3 and all that does is make android hang at boot to where I have to reflash android back to the t999l root66 MK4 stock.

Wifi tethering 4.3 enable- there are a number of these, from zip files to install in cwm to directions on what files to edit and how in the android system. Nothing has worked.

I got this app Wifi Tether Router that supposedly worked, but while I can get it to actually start up without any errors, as far as I can figure wlan0 doesn't exist. When I do a netcfg in terminal no wlan0 entry appears, at least.

I can currently use FoxFi to tether with a usb cable and pdanet, so I'm not that pressed I'd just like to figure out how to get it to work.

  • I assume there is some carrier restriction that means you can't just use the built-in Wi-Fi hotspot feature? – Dan Hulme Apr 1 '14 at 10:21
  • It's that the phone is a t-mobile phone and I am not using t-mobile service so whenever I try to use the built in wifi hotspot it insists my plan doesn't include it because certainly my t-mobile plan doesn't include it as I don't have one. I've tried it with Simple mobile and Go Smart which are both on the tmobile network if I'm not mistaken and neither work, nor allow me to purchase an upgraded service – Ron Kyle Apr 1 '14 at 18:58
0

I'm gonna answer my own question here. Apparently, something I did enabled the built in wifi tethering... before, it would fail when it attempted to validate it with T-Mobile, but now it goes through that part just fine. . When it makes the hotspots, it is named foxfisomething-or-another so foxtrot MIGHT have something to do with it, but I think it was one of the flashable zips. . When I figure it out for certain, I'll update this answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.