0

Total noob here, sorry... I've spent the last three weeks reading up on my issue with no progress at all. I think I have the answer, but need to run this by someone who probably knows!

I modded a stock UK Nabi 2 with nabilab2 from the xda forums, http://forum.xda-developers.com/showthread.php?t=2101277 I needed to do an ota update from Nabi and needed the device to be returned to stock. I lost my original backup so I used the generic stock backup that comes with nabilab2. This put the device back to US stock, with no root privileges or serial number.

There were three ota's, during the instal of the third one, the device crashed - a ton of text sprawled up the screen the device shut down-restarted and booted into <3e> recovery. At that point I had lost TWRP recovery.

Several weeks of reading and falling at every turn... Here is where I am now; The device boots and is usable, I can install apk files and use the tablet normally, however I cannot update. The last ota I need to install downloads via the update service, but fails with errors upon install. I also downloaded the ota manually via the xda forums nabi 2 wiki page and tried to install from the sd card but that fails too. (maybe as my UK stock with serial device, is now a US stock with no serial device, which is causing a signature fail during install of the latest ota?). The device is no longer rooted, so no shell r/w access. I cannot see the device in fastboot. Using the command 'reboot recovery' reboots the device but then it freezes up and is no longer seen via usb. When 'Fastboot recovery' option is chosen in <3e> recovery the device locks up, and the same thing happens when choosing 'Forced recovery'. All signed recovery .zips I have tried to install through <3e> recovery fail with the message 'file verification failed'.

I'm kinda going round in circles with this... I know I need to root to get TWRP back, which allows a custom kernel/recovery to be used, but as I have no Su permission I have no r/w privileges to install the super user files and/or recovery image files to the necessary places. So unless there is some way to get the required recovery files onto the device by the adb command without su access (I'm doubtful of), or via a modded/signed recovery image zip file within <3e> recovery (which again I'm doubtful of, as other signed .zips fail), I'm guessing that the device is bricked?

Any feedback to help solve/answer will be gratefully appreciated.

migrated from stackoverflow.com Mar 31 '14 at 21:55

This question came from our site for professional and enthusiast programmers.

1

Fixed!

I posted a similar question on xda.forums and was pointed in the right direction relating to fastboot protocol.

My device was not showing as installed correctly in device manager and nothing seemed to fix it, re-installing/driver updates etc.

I started from scratch by uninstalling the original Nabi drivers, java, sdk and adb drivers. (I kept windows 8 usb unsigned drivers installed).

I re-installed java, sdk, and adb drivers. I did not install the original nabi drivers.

After re-installing everything, in device manager my device had no conflicts and when fastboot was selected in <3e> recovery I then got the second fastboot protocol menu up and was able to use the command line to send the TWRP image file to the device. ;0)

Success.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.