So I got a new phone (Moto G) about 3 days ago (newest version os) and I've tried to connect to my school's internet, which requires usename/id and password. However, when I try to connect on my phone there's no place to enter my password, only the username. I can hold and select modify network to set the password there, but connecting after that always seems to trigger "authentication issues", even though I know my password is correct because I can connect on other devices.

1 Answer 1


I have a Moto G as well (small world) and also had this problem when connecting to my school's WiFi network (even smaller world).

It appears like the Moto has trouble autodetecting encryption settings on some networks. You can probably get it working by long pressing on the network, selecting modify network, and then changing the 'EAP method' and Phase 2 Authentication' options to whatever your network requires them to be. Get a friend to open their WiFi settings and then copy whatever they have set. A reconnect should grant you access.

Please let me know if you have any questions or feedback.

  • Thanks, this worked. Turns out EAP method had to be set to PEAP.
    – Jimmt
    Apr 1, 2014 at 18:03
  • Glad I could help.
    – jerboa88
    Apr 1, 2014 at 22:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .