1

I have recently updated my HTC One from the stock 4.3 firmware it came with to the stock 4.4 firmware via an OTA update. Since this update occured, I am no longer able to connect to the device with adb for the purpose of installing apps in development on a Windows laptop. adb devices tells me no devices are found HTC Sync Manager is also unable to detect the phone.

However, I am able to transfer files via MTP, something I was unable to do on 4.3 while USB debugging was enabled. Additionally, Windows detects the phone and installs drivers for the device (recognised as "HTC One" though some resources seem to indicate it should appear as "My HTC"). When USB debugging is disabled, it also installs MTP drivers. When USB debugging is enabled, it fails to install MTP drivers and states that the device was disconnected during installation. This does not appear to have any impact on the functionality of MTP however.

However, I have USB debugging enabled under developer options, I have my Android SDK completely updated and HTC Sync Manager fully updated.

I have tried:

  • Different USB cables which did not work.
  • A different phone (my old HTC Desire HD) which still works over adb.
  • Uninstalling and reinstalling HTC Sync Manager & Drivers.
  • Using a USB 3.0 port
  • Not using a USB 3.0 port
  • So you're saying even though the box is checked under developer options, it still isn't letting you install apps through Adb? – Doctor Mooch Apr 2 '14 at 22:14
  • Does the phone think it's connected to ADB? If it does, you get a notification with a little KitKat icon. If you get that icon, the problem's on the PC; otherwise, the problem is on the phone. – Dan Hulme Apr 2 '14 at 22:40
  • @DanHulme Yes, my phone is aware that is connected via ADB. I found the issue since asking this question. – Macha Apr 3 '14 at 18:17
  • Found the solution* Apparently I need more reputation to edit comments here. – Macha Apr 3 '14 at 18:31
4

As it turns out, the issue was that my phone was no longer being recognised as a composite USB device by Windows, meaning only one of ADB, MTP or HTC Sync was capable of running at a given time. After the update, MTP was always recognised first. This explains both the 4.3 issue of MTP and ADB conflicting, and the 4.4 issue of no ADB.

The solution was provided by HTC's support website:

Step 7. If you could see your phone as the portable device on your PC, but there is still no "Android USB Device" in "Device manager", please try to manually update the driver for your phone.

  • Expand "Portable Devices" in "Device Manager"
  • Right click on your phone's name or "MTP USB Device"
  • Update driver software
  • Select “Browse my computer for driver software”
  • Tap “Let me pick from a list of device drivers on my computer”
  • Don’t check “Show the compatible hardware”
  • Select Standard USB main controller
  • Select USB composite device in the right hand side list as the screen shot below and then click Next
  • After you click Next, if there is Warning message window pop up, please choose Yes.
  • 1
    Link to HTC support website is broken. – RenniePet Apr 27 '17 at 10:35
0
  • Make sure cable is connected properly.

  • Try other usb port.

  • Close all programs running that is related to adb.

  • Go to developer Options and tick on USB Debugging.

  • Delete HTC android drivers in device manager and reinsert you cable :) then restart.

enter image description here

0

Try uninstalling the previous drivers and after that connect your device to the PC and let the system detect your device drivers and download it.

0

http://plugable.com/2012/12/01/windows-8-and-intel-usb-3-0-host-controllers

Updating 3.0 drivers from Microsoft to Intel makes HTC devices connect through ADB and FASTBOOT!

  • But following that link, there is this note: "Important Notice: As of Windows 8.1, we don’t recommend replacing the in-box Windows USB 3.0 stack with the Intel Windows 7 stack, as described in this post. This post is being kept for historical background, but we recommend working with your computer manufacturer and/or Microsoft on any remaining issues with the built-in Windows 8.1 USB 3.0 stack." – ToolmakerSteve Sep 12 '15 at 9:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.