2

I have a Huawei Prism II, and my laptop is running Win7. When I connect it to my laptop's USB port, I get a notification that says "Connected as USB storage," but when I go to My Computer, the phone is showing as:

CD Drive (E:) Mobile Partner
0 bytes free of 7.75 MB
CDFS

So the SD card's memory isn't available to transfer files. When I go to the Notifications screen and tap "Connected as USB storage", the radio button for "USB storage device" is already selected. I can select the "Media device (MTP)" option and successfully perform file transfer to/from my SD card this way, but I'm wondering why the "USB storage device" option doesn't make the SD card available.

1

It looks to me you need the USB driver on your pc. Search Huawei site for "USB driver". Also set "USB Debug" on (on your phone, that is. I don't know if this alone would solve your problem, though).

1

My phone is Amoi N828 and I have a similar problem. My workaround is disable the USB debugging :) Then reconnect your phone to the computer :)

Hope this help.

1

SOLVED!

My phone is an HTC Droid Incredible running Android Jelly Bean 4.1. I had the same issue as well, but as Tiana suggested, I turned off USB debugging, rebooted the device (not power off, but actual reboot) and it worked fine.

I had turned on USB debugging previously because I was downloading CM10 but had forgotten to turn it off afterwards.

-1

First Go to [settings]. Then go to (general column). Then go to [developer options]. If you are not getting developer options, then in the same area go to [about the device]. Go to [build number]. Tap on it 5-7 times. Then go to developer options. I guarantee this will help you.

  • 1
    How does going under Developer options helps to solve the problem? There must be a sense somewhere that either I'm missing or the answer doesn't have it. Please explain the reasoning behind your answer. – Firelord Jul 21 '15 at 19:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.