8

I recently moved from Note 2 to Moto X. In Note 2, the 'Mobile Networks' page inside Settings had the 'Network Mode' setting with options: GSM/WCDMA (Auto mode), GSM only or WCDMA only.

In Moto X however, instead of 'Network Mode' there is 'Prefered network type' which has the options: 4G (recommended), 3G or 2G.

Through this I can force 2G, I'm assuming, but not 3G or 4G (there's no 4G in India yet anyway).

Is there any other setting or any app that can force only 3G (or 4G)?

  • 1
    Hello, here feelzdroid.com/2015/08/… is the brief explanation of what explained above with screenshot. This work for all networks like vodafone, BSNL, airtel etc... – Naruto Sep 6 '15 at 19:15
12

Try *#*#4636#*#* in your dial pad (type the * and # also). Under Phone information you will find Preferred network type. Select GSM or WCDMA from there.

You will find

  1. WCDMA preferred this will use both 2g and 3g whichever has the better reception
  2. WCDMA only this will use only 3g
  3. GSM only this will use only 2g
|improve this answer|||||
  • If any one are trying this in dual SIM Moto G, the secret menu is applicable for SIM1 only. – Narayanan May 20 '14 at 7:56
  • Priceless. Locked the network to lte or wcdma only. I thought selecting the option in CyanogenMod would make it stick but it still went back to edge and sometimes GPRS. This time, its locked for Good. – KhoPhi Jun 5 '15 at 0:26
  • Methods to manage mobile network settings: technewstoday.com/… – Junior M Jan 18 '16 at 11:36
  • You saved my cell phone. I was suffering two weeks with this problem. I was not able to use 3G. This tip was incredible. – LCarvalho Feb 10 '17 at 1:33
  • Already added to favorites – LCarvalho Feb 10 '17 at 1:33
-1

Install Network app and try the option WCDMA only.

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.