since a while I receive bluetooth request from my neighbors Harman Kardon media center. Once I accidently 'clicked' the request and suddenly we were connected (no code or handshake needed).

Since I disconnected from the media center, it keeps sending me requests to pair/connect again.

I can of course click cancel on each request, but it keeps bugging me ( approx. every 60 seconds, so it's a sort of a request terror.....).

I asked the neighbor if he can turn it off, but he is not capable or willing to do so.

So I was wondering: can I somehow block this device from sending me requests (well, not from sending of course, bur from my device alerting the request from this particular device)?

I run android 4.2.2 on an Acer v370 (Acer liquid E2)

1 Answer 1


If you are still paired to that media center, then unpair it and turn off you bluetooth visibility, this way media center will not be able to detect your bluetooth, but you will still be able to connect to other devices.

  • I've already done that, turn off the bluetooth visibility. I even changed the name of the device.
    – Michel
    Apr 5, 2014 at 11:09
  • 1
    I think that your phone is the last device that mediacenter was connected to, so it remembers your device and keeps sending you the signals. Don't know if this would work, but try using some friends phone and connect to mediacenter, so when the other phone is gone from your home, mediacenter might remember that phone and stop sending you connection requests...
    – umarhassan
    Apr 7, 2014 at 18:11
  • That worked! connected the mediacenter to my tablet, then turend off bluetooth for the tablet (never use bluetooth on the tablet) and I'm free!
    – Michel
    Apr 11, 2014 at 13:18
  • 1
    It's due to a major bug in bluetooth that has never been fixed
    – David
    Aug 25, 2016 at 1:13
  • I tried this and it worked for me for a couple of hours. But every now and then the visibility changes back to visible and the issue is back as well. But I found the solution - accept the pairing request. Go to Bluetooth settings for this device. Switch off all audio channels. Like 'Call audio' and 'Media audio'. After doing this my phone just ignores the device completely! No pairing, no pairing requests, nothing!
    – Serhiy
    Dec 28, 2019 at 12:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .