5

I have a LAN accessible over wifi that I'd like to connect my Android device to, but when I go to Settings->Connections->Wifi and try selecting the network, it doesn't connect. If I enable internet access on the wifi network it will connect, but then as soon as I disconnect the wifi network from the internet, the phone disconnects from the wifi network. Is there a way to force the phone to connect to a wifi network, regardless of internet accessibility?

The phone is a Samsung Galaxy S4, with Android 4.3. Thanks!

2

Got it - went to Wifi->Advanced->Unchecked "Auto Network Switch." It seems to be something specific to Samsung phones with Android 4.3: see here

  • I still get the same problem even though "Auto Network Switch" is unchecked :/ – Felix Feb 21 '15 at 22:55
0

If you are using a wireless router, what is the brand and model? Your device should be able to connect to the router regardless if you have internet or not. Unless the wireless network was disabled instead of the internet connection. Cheers.

  • I'm using ap-hotspot on my Ubuntu laptop to turn it into a wifi hotspot. When I have the ethernet cable plugged in, my phone will connect to the hotspot network. As soon as I unplug it the ethernet, the phone tries connecting to another nearby network that does have internet. Even if I manually disconnect from this other network, I still won't be able to reconnect to the original hotspot network until I plug the ethernet cable back in. – confusedwifi Apr 6 '14 at 22:44
  • Hi, i guess it is really the case when you disconnect your ethernet cable from your ubuntu laptop. I was able to check this site. howtogeek.com/116409/… – user11738 Apr 7 '14 at 2:36
0

If you have root access to your phone, then this solution is the best in my opinion https://stackoverflow.com/questions/37218510/android-6-0-1-force-wifi-connection-with-no-internet-access

Simply run adb shell settings put global captive_portal_detection_enabled 0

Edit: please upvote original author's post instead of mine

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.