I have tested several Android apps and none of them seem to be able to do what I want.

How do I access admin shares such as \\host\c$ from Android?

Note that admin share access is enabled on the host and I can in fact access it from another Windows machine. Last time I checked it even works from Debian Linux. Now, Android either has some deeply rooted issues with this or it lacks the proper tools/apps.

1 Answer 1


Try ES File Explorer. It can access user shared folders + administrative shares.

  • This app really worked! I tried many different cifs and smb "clients", and also the ASTRO file manager. But I couldn't do it with any of them. ASTRO has a separate CIFS/SMB component you download, but it's not been maintained for some time now and apparently ASTRO can now support CIFS/SMB shares directly within the main app. Unfortunately it only shows user shared folders. No administrative shares, and no way to add a custom network location like with ES File Explorer. ASTRO only allows you to browse user shared folders.
    – Samir
    Apr 9, 2014 at 13:43
  • Worth noting is that it doesn't use UNC notation like \\host\something instead you have to type host\something like that. It has some problems with adding or connecting to admin shares, like for instance I added host\c$ and it was OK, and I could tap to open. But for host\l$ on the same machine it kept saying error, cannot find the server and it won't add it when I tap OK button. When I go back to "server" field and type it in again, and then tap OK, it works then. Looks like a bug.
    – Samir
    Apr 9, 2014 at 13:52
  • False alarm! I have found the culprit. It's not a bug. Apparently when I type in the dollar character $ in any text input field, my Android introduces whitespace. So instead of host\c$ I will get host\c $ with an extra space between drive letter and dollar character. So I have to go back and remove that whitespace. Then it works. This is on a Galaxy S4 Plus. Other phones may not be affected.
    – Samir
    Apr 9, 2014 at 14:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .