I just installed Cyanogenmod 11 on an HTC One, and now I'm completely unable to connect to it via USB from my Linux PC, so I'm unable to transfer any more ROM or applications.

How do I enable USB access, similar to the "USB debugging mode" seen in the stock Android ROM? I've looked through the settings, but there's nothing labeled USB.

  • Are the developer options simply hidden? Where are the developer options in Android 4.2? Commented Apr 9, 2014 at 18:33
  • 1
    So let me get this straight. The stock Android installed by default, designed to be used by Joe Average Sixpack had dev options enabled by default, but Cyanogenmod, which is so complicated to install that only developers can figure it out, hides developer options by default? Who's running this railroad? But no, that doesn't seem to be the issue. I have NO USB access at all. I can't even connect to my phone as a USB mass storage device.
    – Cerin
    Commented Apr 9, 2014 at 18:41
  • 5
    For your first point: HTC may put the developer options somewhere different, but they are hidden by default in vanilla Android builds as of 4.2. So that applies to any Nexus device, or any device with an unmodified version of Android (whereas HTC heavily modifies it). Second point: Mass storage is very different than debug mode, and mass storage mode was replaced by MTP around Android 3.0. If you're using Linux then the issue may be on the PC's side, because many distributions still have difficulty with MTP. Which are you needing: debug mode, or a way to transfer files? Commented Apr 9, 2014 at 18:48
  • Indeed, it seems that MTP does not "just work" on Mac (at least not on OS X 10.9.5), but instead the Android phone that you plug-in via USB is simply ignored (even if you go into your Android phone and set the USB option to MTP). The solution if you want to be able to transfer files on Mac is to install the official application called Android File Transfer: android.com/filetransfer Commented Oct 22, 2016 at 18:21

6 Answers 6


Go into settings > about phone

Toward the bottom of the list, you'll see an entry for "Build Number"

Tap it 5 times and you'll see toast pop-up letting you know that the Developer Options have been enabled.

Go back to the main options menu and tap Developer Options and you'll see a tick box for USB Debugging about halfway down the list.

  • 2
    Works on CyanogenMod 11/Android 4.4.4
    – l0b0
    Commented Jun 24, 2014 at 17:26
  • 3
    On CyanogenMod 13/Android 6, the option was renamed to Android Debugging. Commented Oct 22, 2016 at 18:23

Here's the best solution:

Go to Settings → tap the search bar and type usb → choose Revoke USB debugging authorisation. And now you can enable Android debugging.

  • Downvoters: It may look like a LQ answer but it actually works. I tested it on my COS12.
    – Firelord
    Commented Sep 25, 2015 at 15:09

Though probably not the case for the HTC One, if you have a new/less frequent model, it may be that you need to add the USB Device ID to ~/.android/adb_usb.ini :

First check the USB Device ID by checking what ID appears when you insert your phone:

$ lsusb
Bus 001 Device 049: ID 2970:2282  

Then, add to ~/.android/adb_usb.ini:

echo 0x2970 >> ~/.android/adb_usb.ini

This worked for my newish Wileyfox Storm.


Settings -> Storage -> Press Menu -> USB computer connection

  • That is not even remotely true. Your answer is for popular data transfer methods mainly USB Storage, MTP and PTP with an exception of Phone Charging.
    – Firelord
    Commented Apr 27, 2015 at 23:52

Settings -> About Phone -> Repetedly click Build Number -> Go to Developer Options -> Tap on Usb debuging

  • This is correct, but it's exactly what P Fitz already said two years ago (the accepted answer). It would be more helpful if you can answer some questions that don't already have an answer.
    – Dan Hulme
    Commented Aug 19, 2016 at 12:49

In case some of you have Cyanogen 13 and you wonder where did the USB Debugging option disappear: there is now another option inside Developer options, and it's called "Android Debugging" (and it's disabled by default).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .