I made a call to a local pizza place by dialing their number on my Nexus 5, running ParanoidAndroid 4.2 Beta 4.

The normal behavior that I would expect is the following:

  1. Dial, then do all those phoney-things that I'm not interested in like connecting. (I just want pizza)
  2. Conveniently(?) do an internet lookup of the phone number, then display the business name in my dialer so I know who I'm calling.

However, something weird happened today. It apparently tried to do the lookup, but failed. Instead of displaying "Blah Blah Pizza" in the Dialer, it displayed "Throttle limit exceeded". Everything else worked fine.

There's also a screenshot I managed to take very quickly.

Is anyone else seeing this? What's causing this? More importantly, how can I fix it? I'd rather not see "Throttle limit exceeded" all over my call history.

1 Answer 1


The dialer may have hard-coded the API key for the lookup service. The error occurs when too many requests are sent using a single API key in a short interval.

  • This seems likely. Any information about the API it's using?
    – dotVezz
    Apr 11, 2014 at 12:23
  • 1
    From the source and from using this API in the past: opencnam.com May 18, 2014 at 0:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .