4

I'm using Samsung Galaxy Mega Duos and use two SIM cards - one sim with very low charge for 3G connection (called SIM1) and the other with very-high fee (called SIM2).

I go to Setting - Connections - Data usage to turn off 3G on SIM2 but the checkbox Mobile data seems to be synced between the two e.g. if I check it on SIM1 and then go to SIM1 to turn it off, SIM2 is turned off too!?

My question: How can I turn of 3G for SIM2 but keep it for SIM1?

enter image description here

  • 1
    i think you are looking in wrong area.is there any settings like sim management in setting? i think you can turn off from there – samnaction Apr 11 '14 at 11:29
  • Yeah you are right. Going there get it done. Thank you! – Nam G VU Apr 11 '14 at 12:44
4

I had the same issue. Found this solution on another site:

  1. Open "Settings" App
  2. Go to "SIM Card Manager"
  3. Tap on "Data Service Network"
  4. Choose the SIM as the Data SIM

Note that only the first SIM slot supports 3G Internet. So if you want to use 3G you must plug your 3G SIM in the first slot.

| improve this answer | |
  • Would be lovely if you would give us some URL to refer to what you sate in #4 item i.e. only 1st SIM slot supports 3G – Nam G VU Apr 11 '14 at 12:42
1

With regard to "Note that only the first SIM slot supports 3G Internet. So if you want to use 3G you must plug your 3G SIM in the first slot."

In

Settings --> More Networks --> Mobile networks

You can set the "Network mode" for both SIMs separately, but only one card can be set to fast internet (WCDMA) at a time. This can be especially bothersome if you are in Korea, where parts of the country only have WCDMA and no GSM.

Please also note that mobile data is switched on automatically if you select a SIM card as explained in the first answer. You can then switch it off and on in the "sliding" config menue -- it seems to remember the setting you have made.

JCS.

| improve this answer | |
0

I couldn't find the settings mentioned in other answers (OnePlus with Android 7) so I made an dummy APN setting.

Add a new APN:

Settings > SIM & Network > Sim 2 > Access Point Names > (+)

Now you can add the APN details. Set APN to a dummy domain, e.g. dummy.invalid and hit save. Make sure it's saved and showing as selected on the "APNs" screen.

Note 1: I haven't yet verified this technique as that SIM doesn't currently have credit. Hopefully someone else can verify this.

Note 2: ".invalid" domain is reserved for this purpose. It means your phone won't be trying to connect to a real server.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.