Today I changed my Google password. The next time I turn on my tablet I am suddenly confronted with a "Re-type password" screen - yes, it takes the whole screen. So I jump over to another app to pull the new password from my keychain, but before I can do this, the "Re-type password" screen pops back up. I literally have 2-3 seconds before it pops up again. How am I supposed to get my password if it literally won't let me go to any other screen? How can I disable it long enough to let other apps run? I have tried the "back" button and I have tried the wrong password just to try to force it to give me a rest, but regardless of whether I tell it to retry, cancel, or just let it sit there asking me, as soon as I switch to another app, a couple seconds later it rudely jumps back to asking me to re-type the password.

1 Answer 1


From Settings, go to General:Accounts:Google: and then disable everything from being synced. As soon as this is done, the password prompt will stop popping up. After password is changed, sync can be enabled again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .