2

I cannot connect my Moto X to Windows 7, 32-bit PC via USB. After doing some research normal solutions people found were

  1. Enabling MTP in connection settings.
  2. Disabling USB debugging in Dev. settings.
  3. Updating drivers.
  4. Updating windows media player.

I've tried all of this still my PC can't detect Moto X as USB storage device. It shows the device in - Control Panel\Hardware and Sound\Devices and Printers, but says this device does not work properly as Windows cannot load its drivers. It gives option to re install drivers in troubleshooting but everytime I do it the device driver is not successfully installed.

Here's the snapshot of the errors

  • motorola-global-portal.custhelp.com/app/answers/… try installing this – samnaction Apr 16 '14 at 11:06
  • @sameer I've already installed it... Even tried re installing it several times still it doesn't work. – devansh Apr 17 '14 at 8:51
  • Goto device manager and right click on the motorola device name and select Update Driver Software and click browse and point to the driver location. – samnaction Apr 17 '14 at 10:15
  • It says device driver is already installed... @sameer – devansh Apr 17 '14 at 10:23
  • 1. connect your phone with computer 2. go to C:\Program Files\Common Files\Motorola Shared\Mobile Drivers\ 3. run Motorola Driver Installer.exe, choose clean and Reinstall. – samnaction Apr 17 '14 at 11:02
6

If your phone is able to connect in another PC, the problem is in PC and not with the droid. The possible solutions are

  1. Download Motorola driver
  2. Goto Device Manager and right click on the motorola device name and select uninstall
  3. Now right click and select Scan Hardware Change Now select Update Driver Software and click browse and point to the downloaded driver location

If this does not work Try:

  1. connect your phone with computer
  2. go to C:\Program Files\Common Files\Motorola Shared\Mobile Drivers\
  3. Run Motorola Driver Installer.exe, choose clean and Reinstall.

or

The problem may be due to windows mtp driver and you can try the fix provided by Microsoft.

or

  1. Unistall driver from device manager
  2. Remove all USB controllers
  3. Disable Windows Media Player (Control Panel - Uninstall a program - Turn Windows features on or off - Expand Media Feature - Uncheck Windows Media Player)
  4. Connect your device and Reboot the pc
  5. Reactivate Windows Media Player(Control Panel - Uninstall a program - Turn Windows features on or off - Expand Media Feature - Check Windows Media Player)
  • 1
    I formatted C drive and reinstalled windows.. And now it works without installing drivers too... thanks for the help though... – devansh Apr 23 '14 at 9:55
2

OK, I pulled my hair out for almost 2-days. I'd install the Moto USB driver ware on my PC (Moto Device Mgr V2.5.4) and when I'd connect my Moto X via USB, the driver wouldn't 'install' properly. Status via Cntl Panel, Device & Printer, showed a device named XT1095 (yep that's my Moto X) but flagged with a yellow exclamation point and the declaration 'Driver Not Installed'.

After a NUMBER of uninstall/re-install episodes and delving into the Moto X (turn developer USB options ON/OFF), I tried the setup on my older Dell laptop. BINGO, everything worked like a hose! Hey, what's the difference?

Well, one thing is the Dell hardware is specifically limited to USB 2.0. My desktop PC running a quad core based motherboard has both USB 2.0 and 3.0 ports on it. Hum...

I did a clean install of the Moto Device Mgr and then connected my unlocked/running Moto X intentionally to a USB 2.0 port. KAZOOM, the device driver installed and all was working! Then, I unplugged the Android phone and re-installed it on a USB 3.0 port where it had previously failed to work. VAROOM, it came up and running nicely!

Methinks there's an issue here of technical due diligence in testing the Moto USB driver with various hardware manufacturer specific USB ports...

2

Have you tried unlocking your screen after plugging in the USB cable?

I was having a similar issue - my Moto X would charge but not connect as media device - but none of the above advice was relevant. Finally, I realized that it would not connect as long as the screen was locked. After entering my PIN, it connected immediately. In retrospect, this is a really obvious security feature! Just thought I'd post this in case someone else has also misdiagnosed this as a USB issue.

1

I was facing the same problem with my moto e and windows 7 professional, XP i.e. unable to connect.

Earlier, it did connect with every system but for the last few days it did not. Today an IT person gave me another USB cable (thicker one) and it worked.

  • +1 for the suggestion. After researching different USB cables at cablestogo.com/learning/connector-guides/usb , swapping the USB cable from "Micro-USB A" to "Micro-USB B" solved the problem. The "Micro-USB A" cable did not work because Windows recognized the phone as a generic usb device. On the other hand, both Windows and Motorola Device Manager see the phone correctly when using the "Micro-USB B" cable. – Talkingrock Apr 30 '15 at 22:33
1

Okay this is extremely weird, but I've found this with more than one laptop (one HP and one Acer). For some reason the second USB port from the front of laptop never works with certain devices. My 3G dongle and now my Moto X would not be detected properly and said 'unrecognized device'. I had the same issues as the original question, but after switching ports it just works, every time. Hope this helps someone.

0

I had the same problem. The phone was detecting and showing up as a device, but nothing I did could get it to find anything on the phone. I unlocked it, as one poster suggested above, and that made it want to install the Motorola Device Manager, but that did absolutely nothing for me. I updated the drivers, and still nothing.

Finally, I opened my File Manager app, which is the Cheetah Mobile one available on GooglePlay. It offered me the ability to connect to a computer using ftp and gave me an ftp address. I put that into Windows Explorer and it worked immediately.

  • Note that I opened the app on my phone, not my computer. – anemone Mar 7 '16 at 23:54
0

To make a Moto G device work with Windows 7 computers, go to Settings > Developer options on the device and select USB configuration. Change it to PTP (Picture Transfer Protocol) instead of MTP (Media Transfer Protocol). I have been racking my brains and searching the phone and web for answers. Poking around the phone did it! Good luck :)

-2

Had the same problem and nothing worked until I made sure I was using a USB data cable. Maybe the one I was using is for charging only

  • 1
    This doesn't really answer or attempts to answer the question. OP clearly mentioned that (s)he tried changing USB connection (MTP, USB debugging) which IMO cannot be done if the cable is for charging only. – Firelord Jul 2 '15 at 22:21

protected by Community Jun 29 '16 at 6:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.