3

I am using a Sony Xperia Neo L (MT25i). After updating the OS, my phone not registering to 2G (GSM only mode) network. It works perfectly with 3G (WCDMA only or WCDMA proffered mode) network. While searching for network I can see all the 2G network. I try changed my SIM, but for all the SIM its the same. While googling many are reported this issue, but couldn't find a solution. I don't know whether I am posting this on right place. Since it happened after the OS update I am posting it here. My current Android version is 4.0.4

Update I am from INDIA and my baseband version is 8x55A-AAABQMAZM-203028G-87. Does any one have other baseband on Neo L (MT25i)?

  • Did you try resetting to factory defaults? – user55027 Apr 20 '14 at 8:26
  • yes i tried resetting. Even i tried re-flashing using sony bridge – Shineeth Hamza Apr 20 '14 at 11:53
  • I think this is probably caused by updated baseband. Can you flash older baseband only? – user55027 Apr 20 '14 at 11:54
  • if you don't mind can you provide me some link please... – Shineeth Hamza Apr 20 '14 at 11:56
  • give me few minutes – user55027 Apr 20 '14 at 11:57
1

As it seems you have tried resetting to factory defaults and re-flashing same update, I believe the causes might be caused by updated baseband. I would try reflashing different original firmware. You can also flash baseband only via flashtool so maybe it might be worth trying to flash baseband from the firmware that worked. YMMV.

You can find links to download FTF (original firmware) for your device:

Sources & more info:

  • My bad luck dude.... Its not working. Getting same error while trying to register on 2G network. – Shineeth Hamza Apr 20 '14 at 13:27
  • What error message are you seeing? – Mr. Buster Apr 23 '14 at 17:40
  • @Mr.Buster selected netw. (****) unavailable – Shineeth Hamza Apr 24 '14 at 5:56
0

Try flashing the latest ftf file from here. If you are already in .631 build try flashing the baseband alone. (Try downloading the ftf file again and flash).

  • @ShineethHamza Try changing Settings->Mobile network->Preferred Network->GSM only – samnaction Apr 28 '14 at 11:04
  • @ShineethHamza working?? – samnaction Apr 28 '14 at 12:09
  • Not working dude.... still the same.. ;( – Shineeth Hamza Apr 28 '14 at 12:29
  • Do you know any version of baseband other than 87 for MT25i? – Shineeth Hamza Apr 28 '14 at 12:51
  • @ShineethHamza No I will suggest you to repair via pc companion or SUS – samnaction Apr 28 '14 at 14:33
-3

Simple solution, just reflash radio for your device and it should work. If not contact your provider.

protected by Community Jan 7 '15 at 17:47

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.