2

This question already has an answer here:

My friend brought me a Xtreamer Q mobile phone with broken screen, clockworkmode is working, but USB debugging mode is disabled, I found some posts about how to enable it from adb i tried them and none of them worked. here :

https://stackoverflow.com/questions/13326806/enable-usb-debugging-through-clockworkmod-with-adb and from this tutorial i learnt how to edit build.prop file.

http://www.modaco.com/topic/328943-quick-guide-to-modifying-buildprop-with-adb/ the commands i have used are: adb pull, adb remount, adb push. While i was under clockworkmode i mounted system and i pulled build.prop then i added this line to it persist.service.adb.enable=1, used remount then pushed the file after that reboot, but i couldn't find the device in adb when it have booted normaly. Next i tried to set adb_enabled to 1 in /data/data/com.android.providers.settings/databases/settings.db by following some steps from here

ttp://forum.xda-developers.com/showthread.php?t=774507 and it also didn't worked "The device was not listed". Also i have tried this zip file from clockworkmode it didn't work too...

Install adb enabled setting from zip

My phone do not support USB org cable

my files after editing:

https://www.mediafire.com/?1q13igpc981vydu

marked as duplicate by eldarerathis Dec 15 '14 at 22:37

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Browse other questions tagged or ask your own question.