2

I've bought an Android TV-Box from ebay - it's called R-BOX. I got the device with Android 4.2.2 and root access. However I don't want root. I tried to reset the system and remove root with SuperSU. None of it worked. The vendor software version is RK3066_R-BOX_ANDROID4.2.2-SDK_V1.0.0_130308.

  • Did you look in the SuperSU app settings itself... For a very long time the option to completely remove itself has been there. EDIT: Why do these old questions keep popping up in my feed list? – acejavelin May 30 '16 at 8:48
0

You could install Titanium Backup and freeze the SuperSU app which provides root access on your device. I wouldn't recommend uninstalling it if you don't know how to get it back.

| improve this answer | |
0

I think this device does not contain neither su binary nor SuperUser

So, At the factory level, when the software team releases the firmware build for your device, they have signed it with the public AOSP test keys, thus ro.secure=0 and the adbd is probably insecure, so it will mount your device for R/W with those commands:

adb root
adb remount

Take a look at your Build number if it's ending with test-keys or release-keys

If you have a firmware with test-keys the easiest way if to find another firmware with release-keys

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy