2

I got an issue with GPS on my Sony Xperia M phone with Android 4.3, which seems to work but only intermittently. When it works the lock is acquired quickly, but sometimes it seems that sattelite searching is not even initiated.

searching for satellites no search initiated
the phone is searching for sattelites / the searching doesn't seems to be initiated (click images to enlarge)

For example, above screenshots show how it looks when the phone is searching for sattelites (left), and when the searching doesn't seems to be initiated (right; notice the missing indicators from upper-left). If in the first case the lock is acquired quickly, in the second case the lock is not acquired until the GPS indicator appears on screen (sometime after minutes of waiting).

Did anybody noticed this issue? Rebooting the phone helps, but only for a while.

1

Even the best GPS doesn't lock on instantly. You can use "assisted GPS", or aGPS, to help get a rough fix quickly while you wait for the more accurate GPS to get a lock; this only works when you have internet access, since it uses your IP address to locate you. Go into your device's GPS settings (Settings -> Location access)

Also try clearing the data of the navigation app and installing other gps toolbox apps to see if it fixes the issue.

  • The lock is acquired pretty quickly, the issue is that the GPS doesn't seems to start at all. I found that turning it off and starting it again fixes the issue for a while. The issue happens with every application which requires GPS. – ov1d1u Apr 23 '14 at 15:44
  • 2
    You seem to have your terminology slightly mixed-up: A-GPS uses the Internet or the cell network to download the latest GPS ephemeris data, instead of having to download it from the GPS signal itself. It's a separate thing from the IP-based geolocation you're describing. – Dan Hulme Apr 23 '14 at 15:58
1

Seems that I finally fixed the issue, but I wanted to wait few days to be sure.

First I tried to reflash my phone again, but without wiping my DATA partition (so I could keep my apps and settings intact). This didn't worked, so I fully flashed again my phone's firmware (I was ussing only official firmwares, from Sony) but after a day when my phone's GPS worked fine, the issue reappeared.

Finally I downloaded the same version of the firmware, but for another region (I was using a firmware made for brazilian market, now I'm using the one for Europe) and this seems to work. GPS starts everytime when requested. I'm not really sure where the issue was, but if someone else encounter this issue - maybe you could give my solution a try.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.