I installed kitkat 4.4.2, via clockwork mod and the install went smooth, no issues.

I rebooted, and now all I can is my bootloader and recovery, whenever I try to normal boot. It simply takes me to recovery.

The bootloader states my phone is

*** TAMPERED ***
*** UNLOCKED ***

Which seems fine, it was the same with a previous rom I've used.

I tried a few things, clearing cache, factory resetting the phone etc, no change.

Any ideas where I'm going wrong?

  • When you select "Reboot Now" from recovery it reboots back into bootloader? Have you pulled out the battery and restarted? What did you flash and where did you download it from? – shar1z Apr 24 '14 at 7:29
  • Is it Jelly Bean (4.1, 4.2.2, 4.3) or KITKAT (4.4.2) as you have both in your post and it's confusing. Can you try flasing TWRP recovery instead and see? Did you check the MD5 of the ROM you are using? Have you tried a different ROM? – RossC Apr 24 '14 at 9:48
  • @RossC Hi, apologies for the typos, it's kitkat 4.4.2, I downloaded it from Android revolution. I found the site on from a youtube video of a tutorial on how to install kitkat. android-revolution-hd.blogspot.co.uk/p/…, I installed the latest rom for HTC One. I would have tried to install a different rom, but now I can't file transfer because my phone doesn't recognise the device in recovery mode. Thoughts? – samayres1992 Apr 24 '14 at 10:09
  • @Shar1z Hi, I answered the download info in my reply to RossC. As far as I'm aware I can't take the battery out of the HTC One, it seems sealed off. Any further thoughts? – samayres1992 Apr 24 '14 at 10:12
  • Is there any option at all to Mount the storage of the device, so you can copy onto it. It should be in the recovery? – RossC Apr 24 '14 at 10:33

You need to re-flash your recovery in fastboot. Make sure you use the correct recovery for your device and carrier. (I can provide links if needed.) Your rooted so I will assume you have successfully achieved S-Off which requires proper adb drivers and fastboot.

  1. boot to fastboot (hold power + vol down) and connect USB cable
  2. flash nameofrecovery.img (from same directory adb and fastboot are in) by typing

fastboot flash recovery nameofrecovery.img

  • thanks for the answer, do you know how to add this file while the phone is in the recovery menu? As my computer doesn't recognise the device until it's booted completely, so I'm unsure how I can add the file. – samayres1992 Apr 24 '14 at 10:13
  • Just realized your device has no way to remove sdcard. I updated my answer. – nullmem Apr 24 '14 at 15:51
  • I flashed the recovery with the latest version of trwp. It seems to work fine but I can't seem to use adb to push files on to my android so I can install a new version of kitkat. Any ideas on where I'm going wrong? I can fastboot, it detects my device whereas in adb, it fails to recognise my device. – samayres1992 Apr 24 '14 at 21:24
  • Should be something like adb sideload rom.zip if you still need help when I get home I will update answer with more details – nullmem Apr 24 '14 at 21:55
  • Thanks for the help, it turns out I was having a driver issue, I can now push files etc using push. But now the issue is the files are not showing within my sdcard. I'm using abd push rom.zip /sdcard/rom.zip does that seem fine? and of course thank you for the help. – samayres1992 Apr 24 '14 at 22:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.