3

I used both a Galaxy Nexus and a Nexus 7, running stock Android 4.3 and 4.4, to interact with a Chromecast in the past. Ever since, both devices flood the network with SSDP packets, which seems to be a UPnP related service discovery protocol. "Flood" here means that new packets are sent every second.

A sample packet, decoded by using WireShark, is shown below:

Internet Protocol Version 4, Src: android-28f8778edbb436c2.lan (192.168.200.120), Dst: 239.255.255.250 (239.255.255.250)
    Version: 4
    [shortened output for readability]
    Source: android-28f8778edbb436c2.lan (192.168.200.120)
    Destination: 239.255.255.250 (239.255.255.250)
    User Datagram Protocol, Src Port: 50225 (50225), Dst Port: ssdp (1900) Hypertext Transfer Protocol
    M-SEARCH * HTTP/1.1\r\n
        [Expert Info (Chat/Sequence): M-SEARCH * HTTP/1.1\r\n]
        Request Method: M-SEARCH
        Request URI: *
        Request Version: HTTP/1.1
    HOST: 239.255.255.250:1900\r\n
    MAN: "ssdp:discover"\r\n
    MX: 1\r\n
    ST: urn:dial-multiscreen-org:service:dial:1\r\n
    \r\n
    [Full request URI: http://239.255.255.250:1900*]

As this creates unneccessary traffic and likely drains the battery, I would like to deactivate this discovery feature. But even uninstalling the Chromecast app, Chrome itself, the Youtube app and other likely related apps (essentially everything that interacted with the Chromecast) did not help, the device still sends those packets.

Does anyone know how to disable this device discovery feature?

4
  • I'm not sure, but playing with the controls in Settings → Display → Cast screen might give you a start.
    – Dan Hulme
    Apr 24, 2014 at 20:56
  • Thanks for the suggestion, but that menu item doesn't seem to exist... or would I have to connect to a Chromecast again to get it?
    – jstarek
    Apr 24, 2014 at 21:01
  • This is hopefully a stupid question, but you have tried rebooting the devices (the phone and tabler), correct?
    – derobert
    May 1, 2014 at 20:36
  • @derobert: Of course.
    – jstarek
    May 2, 2014 at 21:29

3 Answers 3

2

I doubt there is a setting on the Phone or on the Chromecast device that allows you to set the SSDP query interval. I've certainly never seen one.


Technical detail

Firstly, 1 UDP packet a second is not a flood. Secondly, it's just the device sending out SSDP probes. This is not a big deal. I think once a second might be a bit much for a discovery protocol - once every 5 seconds for the application might be better, but that's just quibbling over a few seconds. If the device was "flooding" the network with a thousand or more a second, then you'd have a problem.

WS-Discovery (which is a similar discovery protocol) uses the same multicast group (239.255.255.250) but on a different port (3702). Make sure you aren't mixing up SSDP with WS-Discovery probes and responses. If you have Windows boxes on your network, you'll see a lot of (WS-Discovery) messages bouncing around.

Also, in your typical network with Apple devices or AirPrint printers, you'll see a lot of Apple Bonjour (mDNS service discovery) UDP packets flying around on 224.0.0.251. If you get less than 1 UPD message per second at this address, then you have a really quiet network (or some really old devices).

There is likely a bunch of other UDP multicast packets flying about on your network as well.

So, any modern local network with a modicum of devices will have at least 3 service discovery protocols chatting away at any given time - WS-Discovery, SSDP and mDNS. If you have databases or other routers, then you'll have a couple more multicast service discovery protocols firing away. The amount of traffic created by these protocols in the way they are implemented by most devices is just some minor network overhead. Don't worry about it.

1

For me, it was the Plex service. I had to clear it from

   Apps -> Running

and from

   Apps -> Running -> Show Cached Processes

I used iptraf to verify (like top for network traffic) if that helps any...

2
  • Thanks for the suggestion, but I don't have Plex nor other similar services on my device.
    – jstarek
    May 22, 2014 at 16:48
  • Plex uses the same chromecast libraries as it can stream to chromecast devices. Plex was the last "service" I killed upon seeing the chatter stop. The day before I had been using youtube to send to my chromecast, so it could have been a youtube/chromecast process I killed off prior. Point is, I think it could be any app that could cause it, especially chromecast enabled ones. Try killing off all non-essential services until the chatter stops - that's what I did. Your question did point me in the right direction of stopping mine...
    – Dan G.
    May 22, 2014 at 19:31
-1

This may seem drastic but in the long run it may save you time: Have you tried doing a factory reset?

1
  • 1
    Sorry, but that's just a crude and trivial workaround, not an answer to my question.
    – jstarek
    May 1, 2014 at 8:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .