0

Yesterday my front camera on Nexus 5 stopped working. It doesn't show up in any app (& there's a bug in the new Google camera app - I can switch camera only if the HDR+ is on, but then it's stuck on "Can't connect to camera'). I'm out of options, I already tried: deleting cash, reinstalling camera, safe mode, factory reset... - nothing worked. Anybody got another idea how to get it working? Thanks in advance

Threads I found: https://productforums.google.com/forum/#!topic/nexus/6RVMvPaF80s https://productforums.google.com/forum/#!topic/nexus/MATebxlFYyA

0

I found a solution: If you don't have a RMA option like me, it's possible it can be fixed with just disconnecting and reconnecting the front facing camera.

Try deleting cash, reinstalling camera, safe mode, factory reset, etc. before doing this. Proceed at your own risk!

As shown in this video: https://www.youtube.com/watch?v=OPuCmfhzgbg)

  1. Remove the back of the phone (beginning of the video).
  2. Unscrew the top plastic plate (7:15 - 8:10).
  3. Disconnect and reconnect front-facing camera flex cable (13:43 - 13:57).
  4. Put everything back together and you're done.

Viola! I hope it helps someone.

UPDATE: It stopped working again and this didn't help anymore. I had to buy a spare part and according to the video above replace it. The repair was succesful though.

protected by Community Jul 15 '14 at 14:37

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.