I am trying to follow this guide on rooting the Galaxy S3 (Referred to by this A.SE question). I'm getting stuck at step 5.

I have now repeatedly used Kies 3 to reinstall the device driver: Tools > Reinstall device driver. If I connect the phone via USB, and on my PC (Windows 8.1) to to Computer management > Device manager, I find the following entry under Universal Serial Bus controller:

SAMSUNG Mobile USB Composite Device

However, whenever I enter download mode on my phone by holding volume down + power + home keys for 20 seconds, then when prompted pressing volume up key, nothing is found in device manager, nor can the exe in GalaxyS3Root.zip find it. So I exit download mode of the phone by holding the power button for a few seconds and it boots back up. I have tried this process with the USB cable plugged in the whole time, and also while disconnected + connecting it after entering download mode.

Any ideas?

Edit: I did a google search which turned up some things, am trying them:

1 Answer 1


I managed to get it working using Windows 7 to root it. (Following the step-by-step guide without modifications).

The order of things I tried in windows 8.1, each time attempting the rooting process:

  1. Swapped USB ports
  2. enabled developer mode
  3. enabled USB debugging mode
  4. Reset everything to factory settings
  5. Swapped USB ports
  6. enabled developer mode
  7. enabled USB debugging mode

And I had repeatedly re-installed device drivers using Samsung Kies 3 during the above. Nothing worked. So maybe it's just windows 8.1 that stopped things working.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .