2

I have Nexus 7 2013 LTE with Android 4.4.2. I want to set Now SMS as the default SMS app but I have not been successful. After choosing it as the default, the popup is still shown next time I start Now SMS!

Can anyone help me out?

3
  • What are the other options on this pop-up?
    – Chahk
    May 1, 2014 at 16:29
  • It shows a popup "Now SMS needs to be default sms app to work properly" with 2 options: cancel and ok
    – Tuna
    May 1, 2014 at 16:35
  • I tried Mighttext also but it couldnt send a sms to check my balance 3G!
    – Tuna
    May 1, 2014 at 16:44

1 Answer 1

3

Go to Settings, and under the "Wireless & Networks" section tap More.... There should be an option called Default SMS app. Tap it, and select the "Now SMS" app. You should be all set now.

[Edit]:
Apparently, Google deliberately disabled the SMS functionality on cell-enabled Nexus 7 tabs (both 2012 3G and 2013 LTE tablets are impacted) with the 4.4 update. The recommended solution is to flash a custom ROM that re-enables the setting. Keep in mind that this will require unlocking the bootloader, which may void the warranty.

4
  • I tried that so far but the option is not there. It seems that something is missing when i update to 4.4.2
    – Tuna
    May 1, 2014 at 16:42
  • Is the "Default SMS app" option not there, or is "Now SMS" missing from the selection list?
    – Chahk
    May 1, 2014 at 16:44
  • Sorry,i mean that "Default SMS app" is missing
    – Tuna
    May 1, 2014 at 16:47
  • See the update.
    – Chahk
    May 1, 2014 at 16:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .