I have an Android 4.4.2 phone and I enabled ART instead of Dalvik.

When I go to the Google Play Store and try to install Facebook, it can't install the app.

I get two errors, sometimes I get

Invalid installation package

and sometimes

Error -24

Is there a way to know what's going on?

  • 4
    Have you considered the possibility that the facebook app is not compatible with the ART runtime? Some apps may work straight out of Playstore with ART, others don't. ART is not yet ready for prime-time!
    – t0mm13b
    Commented May 1, 2014 at 20:57
  • @t0mm13b Hi! Yes, I considered it. But if you take a look at the ART compatibility list it seems that facebook is fully compatible. Also, every friend of mine that switched to ART can use facebook without issues, even with custom roms. Is there something I can do to try to find what's the problem on my phone? P.s. I also tried installing facebook on dalvik and switching to ART after installation. If I do such thing, the phone goes to reboot loop
    – BackSlash
    Commented May 2, 2014 at 7:57
  • 1
    To add on, facebook works fine for me and im running ART
    – Zac Sweers
    Commented May 3, 2014 at 1:24
  • It's an experimental feature in 4.4. Please direct bug reports to Google. Commented Nov 23, 2014 at 4:42

2 Answers 2


I've had this same problem. To fix it I did the following:

Uninstall Facebook, Wipe dalvik cache via recovery, Reinstall Facebook, Reboot device, Sign in to Facebook.

  • Read the question: I'm not even able to install facebook. And if I install it on dalvik, then clear cache and switch to ART, i get a boot loop
    – BackSlash
    Commented May 3, 2014 at 8:56
  • I'm not saying switch to dalvik, I'm saying clear the cache via the clear dalvik cache command in recovery.
    – 1990clb
    Commented May 3, 2014 at 9:01
  • Tried, it's the same, I can't install facebook
    – BackSlash
    Commented May 3, 2014 at 9:30

Try switching back to Dalvik --> Install Facebook --> switch back to ART. It's working fine for me, i just happened to have installed it before switching to ART


Not the answer you're looking for? Browse other questions tagged .