1

I recently managed to root my Samsung Galaxy S3 by following this previous answer.

However when running the SuperSU app that was automatically loaded after rooting, I get the message:

The su binary needs to be updated. continue?

Then when I click OK, it gives the error:

Installation failed!

I wondered if the version of the SuperSU app installed by the rooting software on my PC was old, so I did this:

  1. Opened SuperSU app
  2. Went to Settings > Reinstall [cleanup for reinstallation from Google Play]
  3. Went to Google Play, then installed this version of the SuperSU app.
  4. But running the new version then gave the same error message.

I'm not sure step 2 worked because it says: "If cleanup succeeds, this app will close automatically in a few seconds. Afterwards, please reinstall SuperSU from Google Play. Are you sure you want to continue?" But then it never closes.

I know the phone had root because I downloaded a root testing app and it confirmed it.

What am I doing wrong?

I tried a number of links (like this one) and couldn't find anything else that made sense to me. Please could someone suggest what I should be doing?

Thanks

1

It turns out I simply had to download a more up-to-date file (which included the Odin executable which runs on the PC, and the .tar that it uploads to the phone) from here, using the table to look up the appropriate file for my device.

For my Samsung Galaxy S3 (GT-i9300) The file was CF-Auto-Root-m0-m0xx-gti9300.zip available from here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.