9

I have a rooted Samsung S4 mini with the latest stable CyanogenMod installed (cm-10.2.1.3).

I was playing with the Google Device Manager (https://www.google.com/android/devicemanager) and tried to lock the device.

When I tried to unlock I found out, there is no keyboard or input box to enter the password into.

The screen looks exactly the same as my lockscreen - I'm using the pattern lock which I remmember perfectly - besides there are just words: "locked" and the message I typed into the web remote lock. I can also see there is Android Device Manager running in background (icon in top left notification corner). Wherever I click or try to draw my pattern lock, the device does nothing (but it is not frozen as I can open the Power button menu).

I also use a custom keyboard application and I removed the original CyanogenMod keyboard. Can this be a problem?

  1. Is there any option at the online Device Manager to remotely unlock the device?
  2. The phone is rooted and I can connect via ADB in Recovery. Can I do something there - besides wiping the device - to unlock the remote lock?
8

In the end I was able to solve the problem by clicking the "Emergency Call" button.

That enforced the keyboard to come up and after closing the Emergency Call screen there was a window to enter Google Device Manager password.

1

Open your terminal and type:

adb shell

Now enter these commands:

su
rm /data/system/cm_gesture.key
reboot

If a lockscreen appears after reboot, it should accept any pattern.

  • This may help when you forget your lockscreen password. But won't help for Google Device Manager remote lock. – Joudicek Jouda May 3 '14 at 21:44

protected by Community Oct 28 '14 at 16:41

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.