1

I'm trying to get TWRP running instead of CWM on my HTX One X. When flashing the recovery through fastboot, and rebooting the phone - the bootloader choice for "recovery" goes straight to CWM.

I tried flashing TWRP through GooManager, and the same thing happens. It kinda seems like the files doesn't get overwritten...

This all started because I wanted to swap the custom rom running (at the moment it's Cyanogen 10.2.0). But even overwriting the boot.img file seems impossible, since all other ROMs just throws the phone in to a bootloop.

The same happens when trying to update to Cyanogen 10.2.1.. (As I've seen many have to manually flash a new boot.img through fastboot)

Any thoughts on how to solve such a case?

Edit 1 -> Commands ran in fastboot:

fastboot flash recovery recovery.img
fastboot reboot

Started phone in bootloader and selected "Recovery" from the menu. CWM shows up and no sign of TWRP.

When trying to flash the new Roms (not cyanogen), I flashed the accompanying boot.img through fastboot.

fastboot flash boot boot.img

No luck, and it get stuck on the HTC-Screen..

  • 1
    Can you post the exact commands you are issuing in fastboot? – Chahk May 5 '14 at 19:00
  • Have you tried flashing using Flashify? – geffchang May 6 '14 at 11:58
  • I have not tried using Flashify no. I'll have a look at that. – xstnc May 8 '14 at 7:38
  • Added more information as you asked for @Chahk – xstnc May 8 '14 at 7:47
  • @xstnc Try different release of TWRP for Your device. – Michal Przybylowicz Feb 6 '16 at 22:27
0

I found, that in my case flashing with heimdall did the deal. In my case, the CM recovery was in the KERNEL partition, so reflashing that partition with an apropriate zImage did the trick for me. The command I used:

sudo heimdall flash --KERNEL zImage

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.