What I did so far

Today I'm trying to get CyanogenMod on my HTC One X+, however I'm stuck now. I successfully unlocked my phone and the phone rebooted and everything was fine so far. Now I wanted to put "cm-10.2.1-enrc2b.zip" on my HTC, which I got from: http://download.cyanogenmod.org/?type=stable&device=enrc2b and I followed this guide: http://wiki.cyanogenmod.org/w/Install_CM_for_enrc2b. However if I booted into recovery mode I still don't boot in ClockworkMod. I also can't select recovery, because then I will get a red exclamation mark (so I don't have a ROM backup, smart of me...). So I saw the note at the bottom of the tutorial which said "fastboot flash boot boot.img", which I did, however the only thing that has changed is that if I normally start my phone it gets stuck in showing the HTC ONE logo and just freezes there. My question is: How do I get CyanogenMod working on my phone?

Summary problems

  • Normal booting device stays stuck at HTC ONE logo
  • I don't have ClockworkMod working
  • I flashed kernel through "fastboot flash boot boot.img" (can't start phone normally anymore)
  • Not sure if "cm-10.2.1-enrc2b.zip" (enrc2b is HTC One X+) is in right location of phone.
  • In recovery mode I cannot select recovery (get red exclamation mark)
  • I can still get into recovery mode and fastboot. I'm still able to send commands through cmd (Windows)


HTC One X+ is not in the list of ClockworkMod: clockworkmod(dot)com/rommanager (Can only have 2 links)

flash boot

It seems I have to rename the /system/recovery-from-boot.p (to /system/recovery-from-boot.p-bak): android.stackexchange(dot)com/questions/18932/why-isnt-clockworkmod-recovery-sticking , but I cannot use an app like Root Explorer anymore, because the device doesn't boot...


How do I get this file on the right location on the phone by using cmd commands? I already copied manually to the phone storage directly in the first folder when you open your phone. Not sure if this is okay?


Thanks for reading this and I really hope anyone can help me. How do I get CyanogenMod on my HTC One X+? I'm a bit desperate in what to do next now. Thanks in advance!

  • As for the lack of CWM, you might wish to take a look at its competitor, twrp, which seems to be available for the HTC One X+. Having a working custom recovery (the link is for enrc2b) should bring you a big step closer to solving your issue.
    – Izzy
    May 6, 2014 at 15:26
  • Thanks Izzy! I got TWRP working by using WinDroid Universal HTC Toolkit v1.1, but I don't know how to properly put cm-10.2.1-enrc2b.zip on my phone so I can flash the ROM. From my current understanding the only things I should do know is first flash the ROM and then flash the Kernel. May 6, 2014 at 15:36
  • I'm not familiar with the device. But if it has an external SDCard, simply put the cm-10.2.1-enrc2b.zip in its root, then boot into recovery, chose to "flash ZIP from SDCard", navigate to and select the zip, and that should be it. Everything needed should be contained within the ZIP. To make sure, read the instructions on the corresponding CM wiki / download page again, but that's as it usually works.
    – Izzy
    May 6, 2014 at 15:40
  • It does not have an external SDCard, but it still has a folder which acts like an external SDCard. The problem is however, how do I put the zip in that folder? As I can not access it by HTC Sync manager. I can't boot my Android at all. What code (in cmd) do I need to push the zip in that folder? May 6, 2014 at 15:52
  • In Windows command prompt try adb push [path-to-zip] /sdcard/
    – Chahk
    May 6, 2014 at 17:17

1 Answer 1


Got it fixed :D with thanks to Izzy and Chahk I did a lot of things so I'm not sure if I write down every step I took, but I hope it will help other users someday. This is what I did.

Restore manger

Install a restore manager (TWRP/ClockworkMod). I used TWRP which I installed by using WinDroid Universal HTC Toolkit: http://forum.xda-developers.com/showthread.php?t=2499926 (If you still have a working ROM, backup this now by booting in recovery mode)

Flash ROM

Check in cmd if your device is recognized with "adb devices". If not try "adb kill-server" followed by "adb usb". Check again with "adb devices". If recognized use "adb push cm-10.2.1-enrc2b.zip /sdcard/" (or your own ROM-name.zip)

Flash Kernel

Now you should flash your kernel, not like how I did it at the beginning. "fastboot flash boot boot.img" in cmd. (Check first if your device is visible with "fastboot devices".

Extra Tip

Install playstore with Gapps or manually by moving "GmsCore.apk + GoogleLoginService.apk" + "GoogleServicesFramework.apk" to /system/app/ and run a playstore.apk (in my case "com.android.vending-4.6.16.apk")

  • I was a bit too hasty about the extra tip about the app store. It runs that way, but still crashes when you try to download an app/update play store (settings --> build version). So I opened a new threat for this: android.stackexchange.com/questions/69018/… May 8, 2014 at 20:17
  • I've flashed the kernel as you suggested in your solution, but at next reboot I indefinitely continue to see the cyan logo with the circular arrow all around. No more. Any suggestions?
    – user90940
    Jan 21, 2015 at 9:15
  • I've tried also cyan roms v10.2.0 with the same result: the cyan logo continues to rotate and nothing appens. Only with v10.1.3 I was able to boot regularly the phone, using the same procedure.
    – user90940
    Jan 21, 2015 at 9:51
  • Gabriele did you find a solution? Sorry I wouldn't know either. I have something like 1 in the 20 boots this problem, but then I just try again. I don't know what the cause is either :/ Jan 25, 2015 at 16:16
  • @GabrieleBertolucci, although just now I failed to upgrade to CM11, I'm pretty confident that your problem is related to Gapps. See: forums.oneplus.net/threads/guide-cm11s-cm12-nightlies.231709 May 16, 2015 at 17:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .