3

My Nexus 10 boots forever. I did (according to the cm-wiki):

  1. Root it
  2. Flash Clockworkmod-Recovery with fastboot
  3. Flash CM11 with sideload
  4. Flash Boot.img with fastboot

Now my Nexus 10 is stuck at the boot animation.

Any ideas?


I tried to wipe dalvik cache in advanced Menu in cwm. When I afterwards choose "show log" I get the following error:

mount: mounting /dev/block/platform/dw_mmc.0/by-name/userdata on /data failed: Invalid arguemnt W:failed to mount /dev/block/platform/dw_mmc.0/by-name/userdata (File exists)

May theres ist the problem?


I flashed stock rom, and this works like a charm. Then I tried to install cm again and twrp. But, twrp tells me, that /data can't be mounted. I tried in twrp (Advanced, Terminal Command):

# mount /data mount: mounting /dev/block/mmcblk0p9 on /data failed: Invalid argument

2

Boot into recovery and get a shell (e.g. adb shell on the PC connected via USB). Then format the userdata partition:

mke2fs -t ext4 /dev/block/platform/dw_mmc.0/by-name/userdata

Afterwards, simply reboot and it should work fine.

The reason why this is necessary is simply (thanks to @utkanos in #cyanogenmod for explaining it): When unlocking the bootloader using fastboot oem unlock it erases all data but doesn't create a proper filesystem.

  • Solved my issue with Nexus10. Could not wipe the device, so was stuck in bootloop. Did not know it was due to this. – twDuke Nov 17 '14 at 16:59
1

Try to enter cwm recovery and do a full wipe factory reset. Wipe both dalvik cache under advanced section and cache.

  • @Tobias If you have any important information on yiur phone make a backup then download and flash that rom via zip file (if there is an option) and restore your data – user65089 May 11 '14 at 13:30
  • @Tobias the log says that system can't mount a partition where the installation is located so there is a serious problem – user65089 May 11 '14 at 13:31
  • I don't have any important data... There's no worry. – Tobias May 11 '14 at 13:35
  • I flashed the stock rom again, and this worked like a charm. I think, this is a good sign... – Tobias May 11 '14 at 13:36
  • Good now do you want a cm11 rom? – user65089 May 11 '14 at 13:37
0

I found a solution. I had to format the partition /dev/block/mmcblk0p9 by hand (with twrp).

I can't remember the command exactly - but more or less it was:

mkfs -t ext4 /dev/block/mmcblk0p9

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.