0

Suddenly, today, the power button stopped working. I tried to turn off the screen and it wouldn't. Everything else works just fine. Eventually the screen timed out, and wouldn't turn back on. Plugging it into a charger turns the screen back on, but that's fairly useless away from power...

I had heard that soft reset (power button+volume down) fixes it, but not even that worked. It would only register it as volume down. I plugged it into adb and rebooted it that way, to no avail. What can I do?

1

The power button is handled at a very low level by something like a watchdog, so if it's not working, the problem is probably in hardware, not software. That means it probably needs physically replacing. Take it to a repair shop and have them check it out.

Even if you don't think you did anything to break it, it could be the result of an earlier impact: e.g. it cracked the circuit board, but only after continued use has the crack broken the electrical circuit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.