2

I have a Nexus 4 running stock rom kit kat 4.4.2. There were few instances, in which when the phone goes to sleep, I see the notification light blinking indicating a new email/message, but it doesn't wake up when I press the power button. I have to soft reboot the phone {press the power button for 5 seconds to turn it off, then turn on}to use it again. This happens more frequently on some days, and some times it doesn't happen for weeks.I tried calling the phone from my land line when it is in this state, I could hear it ringing on the landline, but the phone doesn't actually ring. After rebooting, it doesn't even show a missed call. When I reboot it, the phone's battery is substantially less (down by about 10%). It started happening only since 4.3 JB update, it was fine till then.

I tried a full factory reset, and minimal apps, it worked fine. Once I installed all my apps back, this started happening again. I am thinking one of my apps is causing this and it could be an application or a bug in Kit kat/JB itself.

  1. Is there any known bug in kitkat 4.4.2 (or >= 4.3 ) or is there any application known to cause this?
  2. Is there any way I can look at the logs to see if any specific application is causing this.
  3. Force wake up the phone without having to reboot it ?
  • FWIW, I also have a Nexus 4 on 4.4.2 and I've not experienced this problem. By what you say this does sound like some kind of problem app? – MrWhite May 13 '14 at 14:55
  • 1
    Update - I have removed the following apps - Yahoo mail, Outlook mail, Temple run 2, Mtorrent, Microsoft office, Speet Test and it seems to have corrected the problem. Will install these apps back one by one and will post updates – Dinesh May 23 '14 at 7:38
  • 1
    Update - It seems to be a bug with Temple run 2, with notifications turned off using the andriod settings -> apps -> temple run 2 -> show notifications. I guess if there is a push notification from the game, the phone goes into a comatose mode. I am yet to confirm this, and if that is infact the problem, Will notify the developers. Can some other Nexus 4 owners try this and see if you can reproduce the bug? – Dinesh May 29 '14 at 13:57
  • I have the same issue, but no Temple run 2. And only after upgrading to android 5 (Lolipop, official ota version) – Jaap Dec 12 '14 at 13:41
1

You might wish to run adb logcat for investigation. But that might only be helpful if you know how to trigger the issue.

Another approach would be, as you already indicated:

  1. start with a factory reset. You know that with a "fresh device" the issue does not happen, as described by your question
  2. install back only a part of your apps (the ones you feel most essential), but not more than ~50%. See if the issue still happens.
    • Yes: the problematic app was in this batch
    • No: the problematic app was not in this batch
  3. start over at 1., this time with the other half. Does the issue show up again?

If 2. + 3. are answered "No", it might as well be a combination of apps. If the issue shows up only in either 2. or 3. (but not in both cases), start narrowing down. I will assume here it was part of 3., switch items if it was the other way around:

  1. starting over with factory-reset and installing the first half of your apps.
  2. split the other half in two again, and repeat as above

This procedure should help you finding the culprit, while still being able to use your device and as much of your apps as possible. Of course, you could also start with factory-reset and then install each app one-by-one (which might be the safer approach) – but as the issue might not show up immediately (may even take a day or more), the above might be more practical.

  • I am now trying something similar to what you have suggested, Started removing the apps one by one, while trying to see if that solves the problem. Will keep you posted. – Dinesh May 14 '14 at 10:32
1

I have this issue with a Galaxy Note 2. The only way I was able to solve the issue was by installing the app 'Wake Lock' from Google Play Store and set it in 'PARTIAL_WAKE_LOCK'. Also set Autostart on boot. This way you will never have that issue again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.