0

I've got a rooted Samsung Galaxy Nexus running Android 4.3 (Jelly Bean). Since a week I can't find the contacts app. Seems like it disappeared. It is NOT disabled (I've already checked). I also tried to re-install it, using the .apk placed in /system/app, but the installer fails ("Application not installed"). Does anybody know how to fix, or should I better factory-reset my phone? I know this is a solution, but I'd prefer to fix it...

Thanks in advance

Giacomo

0

The install fail is likely due to your system being read only. If you use es explorer, select tools and root explorer, and remount system to rw and try to install again. Also make sure your launcher (if it allows hiding icons) isn't hiding your contacts app

  • I installed es and activated root exploring. Then I remounted /system partition with rw permissions. Still same error...mount|grep "system" returns this /dev/block/platform/omap/omap_hsmmc.0/by-name/system /system ext4 rw,seclabel,relatime,user_xattr,barrier=1,data=ordered 0 0 – Giacomo Fabris May 13 '14 at 20:06
  • I forgot: I am using the default android launcher, so no way out to hide icons...anyway, I also can't see the contacts app from settings→app – Giacomo Fabris May 13 '14 at 20:13
  • Try adb shell su -c "mount -o remount rw, /system" then adb shell su -c "/sdcard/contacts.apk /system/app/" – kyle May 14 '14 at 14:53
  • You wrote /sdcard/contacts.apk. I have no external contacs.apk package. The only one I have is the one placed in /system/app. Should I download a new one? – Giacomo Fabris May 14 '14 at 14:56
  • Ah, okay. What you want to do is look for your roms contacts.apk online and copy it to your sdcard, then move it to system/app and reboot. It should reinstall the app – kyle May 14 '14 at 15:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.