5

A few days ago I deleted all of my Android contacts (using the "Delete Contacts" app). Not a mistake, I really want to delete them.

From that day, Android always shows a notification "Sync: Too many contacts deletes".
When I click on it, a menu comes:

Delete limit exceeded
There are 3960 deleted items for contacts, account xxx.xxx@gmail.com. What would you like to do?
- Delete the items.
- Undo the deletes.
- Do nothing for now.

When I click Delete the items, the menu disappears, and nothing seems to happen. The contacts are gone but the notification still sits there. It has been like this for days. What should I do?

  • Did you ever manage to resolve this? – Nathan Fellman Feb 15 '11 at 10:36
2

Just keep selecting the option to Delete items anyway. Each time you do, about 50 contacts more will be deleted.

1

Your phone is linked to your Gmail account? If you log into your account in a web browser and click on "Contacts" in the lower left, does it still show your deleted contacts there? If you can fix up the list there, it should (?) sync to your phone.

  • I have zero contacts in GMail. But "Sync: Too many contacts deletes" always appears on the phone :-( – Nicolas Raoul Sep 6 '10 at 2:53
1

This happened to my wife's phone too, but I don't remember exactly how she fixed it. I think what she did was disable contact sync, then go to Gmail on the web and delete all the contacts from there, then re-enable contact sync on her phone.

  • What worked for me: I deleted all contacts using the Gmail web interface, then rebooted the phone. – Nicolas Raoul Jul 26 '10 at 2:38
  • I speaked too fast, the icon reappeared :-/ – Nicolas Raoul Jul 26 '10 at 9:10
1

My phone is rooted.

  • I made sure all of my data was correct at www.google.com/contacts .
    Then exported the data (.csv file) from Google’s web site to my home computer for safe storage.
  • I used the app Titanium Backup to “Wipe data” for the apps Contacts 4.0.3 and Contacts Storage 4.0.3.
  • Waited (approx 1 min) for my phone to re-sync with google and all of the contacts were restored.
  • Finally, I went back into Titanium Backup and preformed a full back up for apps Contacts 4.0.3 and Contacts Storage 4.0.3.
0

After switching to Android 2.2, it works better. When the icon appears, just click to continue, and after a few times it is done.

0

I was having the same problem as you are now. Here's what I did in the Gmail app:

  1. Go to your Gmail account
  2. Press menu buton
  3. Press settings
  4. select your mail id
  5. Under data usage
  6. Uncheck Sync Gmail.

That should do the trick. It worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.