0

I am trying to download a game from Google Play to my VirtualBox. The site (browsed with my Windows 7 laptop and Firefox) says the app is compatible with all of my devices.

screenshot

I happily clicked the install button, and Google Play site said the app will be installed on my device soon.

screenshot

However, my VirtualBox reported a failure: the app cannot be downloaded due to an error. (942)

screenshot

Clicking the notification led to the a dialog with the app cannot be downloaded due to an error. (942) again, and at the bottom-left corner was a message saying that my device isn't compatible with this version, which is a conflict with what Google Play site said as in the first paragraph.

screenshot

I am using Oracle VM VirtualBox 4.3.10 with Android-x86 4.3 in Windows 7 Ultimate SP1 (64-bit). My question is: Is my device compatible with the app? And if it is, How can I install it?

(And an off-topic question: How can I complain this to Google for the conflict?)

  • 1
    I am sure it has something to do with the fact that you are running it on a VM. And I am definitely sure that Google wont provide support for an installation of this nature. Maybe you can try the Google forums. – bobbyalex May 16 '14 at 5:19
2

That's not a Play Store compatibility error that you're getting on your device, that's an install error which says that it's having problems installing the app on your device. The Play Store only checks some basic specs of your device (like OS versions, screen size, RAM size, whether or not there's a camera, etc) it can't tell remotely whether or not there's a problem with your device.

There are a few threads on the internet that talk about getting error 942 when installing apps, and they seem to suggest that it's a problem with the GoogleApps on your device. Either there's a data corruption in the GApps, or there's a problem with the version of GApps you've got installed.

See some of these for more info:

The two main solutions that worked for people are clearing the application cache on Google Play Services, and Google Services Framework:

To clear the app cache:

  • Go to Settings > Apps > All then find the following entries in the list Google Play Services, Google Play Store and Google Services Framework go through each of those and select Force Stop (if available) and then Clear cache

The other solution that has worked for people using non-standard ROMs and installs like yours are to double-check the version of the Google Apps package that they've downloaded and installed and make sure that it really is the right version of GApps for their device and OS version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.