3

So I'm trying to run fsck on my sdcard's ext4 partition and it doesn't work for some reason.

sh-4.1# fsck /dev/block/vold/179:2
fsck (busybox 1.21.0-Stericson, 2013-01-28 21:49:55 GMT)
fsck: fsck.auto: No such file or directory

Any idea why is says "No such file or directory"?

6
  • You shouldn't run fsck on a mounted device anyway: you need to unmount the device first so that fsck is free to make changes to the filesystem.
    – Dan Hulme
    May 19, 2014 at 17:05
  • @DanHulme I unmounted it successfully and tried running fsck, I get the same message.
    – Irfan
    May 19, 2014 at 17:23
  • Have you tried running fsck.ext4 directly? (I'm not certain if it exists in busybox, but it's worth a try) May 20, 2014 at 5:33
  • @onik Nope, the fsck.ext4 applet doesn't exist. I could simply do fsck -t ext4 for the same function (right?), but I get same error as mentioned in this post. I'm guessing this is some issue with the binary bundled with busybox or maybe a permission error?
    – Irfan
    May 20, 2014 at 16:30
  • I have same problem here, but my SDCard has a vfat partition. So, it could not be an issue with Ext4 only. I have busybox 1.22.1-Stericson, 2014-01-25. Jun 24, 2014 at 0:22

1 Answer 1

1

You likely need to include the util-linux-fsck package into your busybox image. The warning is saying that there is a file missing which the util-linux-fsck package provides.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .