I've only had my Samsung Galaxy S5 for about a week now. I've been mowing the lawn whilst listening to music. Every so often, the music would stutter or skip to the next track. When I took my phone out of my pocket, it was still locked, but awake. And on the lock screen whilst playing music are controls to pause and skip tracks. So I'm guessing that the home button is being pressed by my leg and the controls on the screen are being pressed.

Is there some way of making it so that the home button does not wake the device, or at least not when it's in my pocket?!

  • It is very unlikely that the songs are being skipped because of the on screen buttons. All smart phone screens now a days are capacitive. You need something conductive, like your skin, to touch the screen for the buttons to be activated.
    – bobbyalex
    Commented May 23, 2014 at 1:15
  • 1
    Hi Bobby. The Samsung Galaxy S5 screen can be operated with gloves (any gloves, not just special capacitive gloved). Is also has a feature called Air View, which allows you to do some things without actually making physical contact with the screen - you just hover your finger about 5mm from it and it somehow detects it's there and reacts. Very clever technology, no doubt. But I just want to stop my phone waking up and doing stuff when it's in my pocket. Commented May 24, 2014 at 14:16
  • Matty, is air view enabled on your phone? If yes, do you use it?
    – bobbyalex
    Commented May 24, 2014 at 14:50
  • @BobbyAlexander No, I have both Air View and extra Touch Sensitivity turned off. I only looked at Air View because I was curious to see what it was. Commented May 24, 2014 at 21:39

6 Answers 6


If you rooted your S5 it is pretty simple (and you don't have to install third party apps):
1) use a file manager and go into root -> system -> usr -> keylayout and find the file gpio-keys.kl ;
2) Open it with a text editor and find the lines with "WAKE" written in them;
3) Go to the one with "HOME" written in it and just delete this word and all the spaces between the number on the left and "WAKE" on the right; 4) Save the file and you're done;

If you can't do this 30seconds thing because your S5 is not rooted then I'd suggest you to root your phone: a new world opens right in front of you ;)


I don't think you can without installing a custom ROM.

  • Unfortunately, I think you're right. I can't find anything online to suggest that it's an option built into the standard firmware. Seems like such a trivial thing that they could easily add to an OTA update in the future. :( Commented May 24, 2014 at 14:18
  • Yeah, it would be but I don't see them implementing it, good luck if you decide to install a new ROM. Just comment back here if you need any help.
    – user61232
    Commented May 25, 2014 at 15:02

If your phone is rooted (recommended for so many reasons), you can install Xposed Framework and a module called Wanam Xposed. After you've installed these and rebooted your phone, open Wanam Xposed, go into "System," scroll down to "Disable wake HOME button" and put a check mark in the box. Reboot your phone again to apply the change.


If anyone is searching for a solution here, here's what I did. I use the "SlideLock" app for my lock screen. This way I get iOS style notifications on the lockscreen. In the "Settings" >> "Lockscreen" for SlideLock, there's an option to "Block home button" - prevent unlocking the device using the home button. I activated that, and now that stops accidental activations or turning on of the phone. Hope that helps. :)


Get a case or cover for your phone that covers the home button.

Your phone will still have the same functionality and will be protected from accidental wakeups. Additionally it will also be protected from scratches


Get a s view case. Not only does it have room cut out for the button, the magnets stop the phone also to unlock..

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .