12

So, the touchscreen on my Nexus 4 broke this weekend. I have a new device coming in, but in the meantime I need to be able to access the device to use a few different apps and send/receive some SMS messages from it.

I found this guide on reddit: http://www.reddit.com/r/Android/comments/1r2zha/how_i_managed_to_use_my_android_device_with_a/

It's not exactly simple, but it should work.

Unfortunately, I discovered that in order to use ADB shell commands, a pop-up window should appear on the phone to allow/disallow USB debugging. (USB debugging is enabled already, but there appears to be an additional 'authentication' step)

Unfortunately, I can't use the phone's touchscreen, so I can't unlock it or tap the notification that will allow me to authenticate the phone.

Is there a way I can get around that authentication step?

The device is unlocked and rooted.

  • 1
  • @GAThrawn No, that question is about the opposite problem, where touches work fine but the screen doesn't display anything. In this case, the screen displays, but doesn't respond to touches. – Dan Hulme May 28 '14 at 11:01
  • Unfortunately, no there isn't. You just put your phone in a loop. You might just have to wait for your new phone or have your old one refurbished. – user82546 Dec 3 '14 at 18:16
3

I figured this out on my own. I solved this by installing Airdroid using an OTG USB adapter and a wired mouse. I then used the airmirror capability of the software to control a virtual mouse on the device. I do have root on the device, this may be significant to the operation of Airmirror. I could then accept the debug confirmation on the screen and complete the backups I wanted to do.

1

I'm sure this is not exactly the answer you're looking for, but this could solve your problem:

If your Nexus works fine otherwise, why don't you just plug a mouse and keyboard (via USB OTG or Bluetooth) and pretend your Nexus does not have touch screen?

Anything, including allowing USB debugging would work as the mouse cursor is even usable when your phone is locked.

  • The stock Nexus 4 doesn't support USB OTG. You need some hacks to enable part of it. – Jb Drucker Jan 22 '17 at 19:52
  • Worked perfectly for me! In my case I am running Lineage with the TWRP recovery, I'm not sure whether my device natively supports a mouse and keyboard in the stock ROM but it did the job in my case! – Ben Jul 30 '17 at 4:03
1

Well with the boot loader unlocked you can temporarily boot up into recovery by using fastboot:

fastboot boot recovery-clockwork-6.0.4.7-mako.img

This will then give you adb access to your device to get files off etc. The adb debug mode could then be turned on by editing a settings file and copying in the crypto keys generated by adb on the host computer. I've done the latter before but not the former, which could be an issue.

Update - To reboot into fastboot mode do: To get into fastboot mode power off the phone, if nothing else a very long press on the phone should work if all else fails (I don't want to confirm this on mine and crash it!). Then power on holding down the volume down key and the power key together. If you can't see the display (I gather you can but you can't use the touch screen) then hold the buttons down for about five seconds and it should vibrate to confirm. Then use the above command to load custom recovery and gain adb access. This all assumes that the boot loader is unlocked, as stated above.

0

I saw this on a different thread, after searching online for hours and hours....seemed to help a few out so I am re-posting here...

"This just happened to me!
Phone works but screen and LCD broken and unresponsive. I had a screen lock too so what I did was I took off the back plate, removed the battery, and unscrewed the six screws to uncover the PCB board under the back housing. Then I carefully disconnected all the tiny ribbon connectors.

I waited a minute just to be superstitious and then reconnected all the ribbon connectors and put everything back to how it was. Then I downloaded Kies from the Samsung website, pluged my phone into a computer via USB and was able to view all my files!

Something about disconnecting the PCB board resets the default settings to factory state but doesn't delete any data at all. Good luck and I hope this helps someone out there."

Source: Android Central

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.