I have a Samsung Galaxy Nexus with Cyanogenmod 11 11-20140225-SNAPSHOT-InstallerXNPQ09P-maguro Android 4.4.2 KitKat with CWM It's a stable installer build.

For a while now I have been getting been getting a 'Unfortunately, Settings has stopped.' error, when trying to simply open Settings from the home screen or application drawer.

It also happens if I try to run the app (com.android.settings) in other ways such as opening a third-party keyboard's settings (which tries to open 'Language & input' within the Settings app).

I have tried the following things, to no avail:

  • Wipe Dalvik cache in CWM
  • 'wipe cache partition' in CWM
  • Fix permissions using the 'ROM manager' app
  • Did 'Clear data' for the Settings app (by dragging it to 'App info' on home screen)
  • Installed AROMA Filemanager in CWM, and, not finding anything to delete in /data/data/com.android.settings/cache/, but deleting /data/data/com.android.settings/shared_prefs/CMStats.xml
  • Botting into safe mode, where Settings app STILL crashes.

I will note that the Settings app still sits in the multitasking list, but when you try to open it from there it still gives the same crash error.

I'd like to try and avoid a factory reset if possible, so are there any steps I could try further before an entire factory reset?

Could it be having selected ART mode that eventually mucked up Settings somehow? If so perhaps I could turn it off manually via Terminal/adb and then reset Dalvik again or something?

Whatever it is, what troubleshooting steps could be done in addition to the ones above?

  • Are there any hints what goes wrong in logcat?
    – domen
    Jul 25, 2014 at 14:07

2 Answers 2


I had the same problem where settings would keep on crashing. I just got the snapshot today and it did the same thing. After experimenting I fixed it by going in the app drawer and holding on setting, opening its app info, and clearing data. It now opens and works well. I hope this helps.

  • Thanks, I had flashed a rom(CM11) without cleaning data(old rom slimfox), and this worked for me, before this settings was crashing in developer options
    – Karthik T
    Jul 27, 2014 at 12:04

Going into the app info may also trigger the crash. One possible way to avoid that, is to use adb:

 adb shell pm clear com.android.settings

Now clearing the app data may not be enough. I had to do, as root:

 rm -fR /data/data/com.android.settings

You must log in to answer this question.