0

I have telus samsung galaxy s2x with android jellybean 4.1.2 (non rooted).

When going on play store I got an error about authentication needed. So I did uninstall updates from application manager (as described in this answer). Now the play store app got replaced with com.android.vending, which is like the old "market" app.

That app seems to crash frequently. How can I restore the new play store app again?

  • First, "authentication needed" means you've got to enter your credentials (so I don't know what made you uninstall updates). Second, the playstore app usually auto-updates itself; but in a state where "authentication needed" is asked by it, I'm not sure whether this auto-update still works. If it does, it usually takes between some minutes and a few days. So how long ago did you uninstall updates? And does this error message for authentication still appear? – Izzy May 25 '14 at 11:03
  • I got the idea from the selected answer here: android.stackexchange.com/questions/20369/… – omega May 25 '14 at 16:30
  • Ah, OK – thanks! I've integrated that hint with your question. And I see you've found your answer, good news :) – Izzy May 25 '14 at 16:43
1

Android Police has all the apks. Here's the lastest one.

  • reinstalling the app fixed it. – omega May 25 '14 at 16:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.