1

After using the standard android on my one X+ for a long time, I decided to get started with cyanogenmod today.

I started by using this manual: http://wiki.cyanogenmod.org/w/Install_CM_for_endeavoru I already rooted it a long time ago, so I skipped everything up onto installing recovery.

First I tried installing the enrc2b, but this gave me the error that my phone was a endeavoru (A bit strange, because everywhere they say that's a HTC one X, while mine is definitely a HTC one X+). After that, I continued with the version for the endeavoru and successfully installed cm-10.2.1-endeavoru.zip on it.

After rebooting it, I got stuck on a endless boot screen of cyanogenmod. I noticed this line in the description:

his device, if unlocked with HTCDev Unlock, must have its kernel flashed via fastboot. Extract boot.img from the CyanogenMod .zip package and flash it from the bootloader with: fastboot flash boot boot.img

I have no idea if I rooted it with HTCDev Unlock, I did it a long time ago, but I thought I would give it a try. After executing fastboot flash boot boot.img I rebooted, and now I am stuck at a endless HTC splash screen.

I can still get to the fastboot and recovery menu, but have no clue where I wned wrong and how to continue. I already tried a factory reset, but to no avail. I also tried getting the backup that I made back from recovery, but it says it can't find any backups.

any ideas how to continue...?


I got a little fit further. When I look at the boot screen, it should clearly be a enrc2b

enter image description here

I downloaded cm-10.2.1-enrc2b.zip , extracted boot.img and flashed that onto it. This at least brought me back to getting stuck at the cyanogenmod screen instead of the HTC screen.

After that I tried to install cm-10.2.1-enrc2b.zip onto it, but that's giving me this error:

enter image description here

  • Your device is S-ON. You should have put it to S-OFF before flashing – aureljared May 26 '14 at 4:58
  • There's no mention of that anywhere here: wiki.cyanogenmod.org/w/Install_CM_for_enrc2b Also on other pages they mention you don't need s-off as long as you got the custom recovery working. – ErikL May 26 '14 at 7:07
  • 1
    Hmm okay, well have you tried removing the whole assert() line from the CM updater-script? – aureljared May 26 '14 at 9:15
  • I thought that would be a long shot, but that actually worked! I now got a booting phone again with cyanogenmod, thanks! I will later add a description how I got it working. – ErikL May 26 '14 at 19:07
  • Okay, I'll put it as an answer. – aureljared May 27 '14 at 0:53
1

In the CyanogenMod zip's updater script, remove the entire assert() line. That will remove the device identity verification and will let the recovery commence flashing immediately.

-1

reflash the rom, dont reboot into system, reboot to fastboot or bootloader (if so go to fastboot) then do fastboot flash boot boot.img) (you need to extract this from the rom zip you installed)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.