2

I have purchased an LG Optimus Zone 2 to develop on and I have removed all of the drivers for the phone on my Windows 7 machine. I downloaded the OEM driver from LG and disconnected my network. After installing the OEM driver, I connected my device to my computer (and I have already enabled developer mode on my device and selected USB debugging), but when I run adb devices, it says that no devices are connected.

Clearly it is installed on my machine because in compmgmt.msc it says that it found the LG Android MTP, and on the device itself it asks me for internet connection/MTP/camera or just charging mode (I always select the MTP mode).

I for the life of me can't figure out why it won't connect (I'm trying to test an app locally on the machine). Could anyone help me with this issue?

3

Rebooting the phone and setting it to connect via USB as Internet Connection -> Ethernet worked for me.

LG also has drivers on their site (http://www.lg.com/us/support-mobile/lg-VS415PP) but I'm not sure they're necessary for this to work, and even with them installed ADB only works when in Ethernet mode.

You're not wrong to be frustrated, though - I've been developing for Android since 2009 and have used dozens of devices, and I've never once had one that required a setting like that for ADB to work (at least not any Google-certified official devices). Weird.

EDIT (Aug 25 2014) - Looks like after the phone is rebooted or unplugged, sometimes it "forgets" its connection mode, or tries to connect as an installer even though it's still set to do an Ethernet internet connection. Re-selecting the statusbar notification and setting it back to internet+ethernet again works, but it's kind of annoying to do regularly. Then again, for the $25 I spent on this phone, I suppose I can't expect too much...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.