1

I have a Samsung Galaxy S3 (i9300) that I've been using for slightly over a year. I am a rather heavy-duty user of the phone, and have used in intensively for that time. I do take care of the phone though, so I doubt if physical damage was a cause of my problems.

A few months ago, I moved from Cyanogenmod 11 Nightlies to CM11 Snapshot releases. When I updated to CM11 M6 a few weeks ago, I started noticing dramatically reduced battery life. Not immediately, but in the days following the update I noticed my battery would drain from full to emtpy in about 5 hours, even if I left the phone unused. I turned off all non-essential features on Android, don't run apps in the background, et cetera.

A week or so ago, I started noticing strange behavior. The phone would freeze up, and then spontaneously turn off. If I rebooted, it would sometimes reboot successfully, other times it would freeze during boot. I did a wipe and reinstall of CM11 M6, but the problem persisted. I noticed, though, that whenever the phone did this and I did manage to restart, the battery would be about 30% lower than it was before the crash. I also noticed that a few seconds before every crash, my screen would start to flicker, as if certain horizontal lines suddenly had their brightness levels fluctuated. However, if the phone did refuse to boot up and froze during boot, if connected to a power source by the charging cable, would be fine. I've also never had the phone freeze while charging.

I suspect that my phone's battery might be going. Am I right in this suspicion, or am I missing something?

  • First off, what is using the battery? Or is the battery section in CM just not giving anything useful? – Colin May 27 '14 at 2:12
  • Nope, nothing useful by my account... I says that Screen is using between 30% and 50% of the battery even when I turn the Screen off for most of the time. The second highest usage is Android System and third is Android OS. This indicates (I think) that the battery is draining at an accelerated rate and that it's not providing a stable current... But I'm not sure if I'm right? – user61551 May 27 '14 at 11:02
  • I have this exact same problem. My phone freezes all the time. I found a solution that gives me a lot less freezes a day. Go to Settings > Performance (Just above about the phone, if you tabbed the buildnumber 7 times) and put the governor on Performance. I know your phone will run at full speed but the freezes are gone (for me). So is it a problem with the cm kernel? I did however change to boeffla kernel yesterday, but that was even worse. – Kees Sonnema Jun 2 '14 at 18:27
0

Since the issue started when you first flashed CM11 M6, and you have stated that you have performed a wipe and re-install of CM11 M6, have you tried wiping and reverting back to an older version of CM from before you started having issues?

  • That's a good point; I'll try that out sometime soon. I still think it's the battery, but your advice could be the answer. – user61551 May 27 '14 at 14:53
  • Just tried flashing an older version of CM11 Snapshot; exact same problem. My screen kinda looks like when a bulb starts flickering in a horror movie, except not so drastic. The battery also gets really hot after about 2 or 3 minutes of intense use when disconnected from the power supply; if left connected to power, it seems fine. – user61551 May 27 '14 at 22:44
  • Are you using a stock kernel? Is the device overclocked? It may be worth putting the device back to stock (Via Kies), to see if the issue persists. – n8udd May 28 '14 at 10:50
  • Nope, as CM flashes its own kernel when it updates, I'm running the latest stable CM kernel, it seems. And the device is not overclocked, so that's not the problem either. – user61551 May 28 '14 at 16:04
  • I can try flashing back to stock kernel, but that seems like a tremendous amount of trouble to go to just to double-check something which seems to be a battery problem (as the problem disappears every time I connect a power source). I'll try to get a friend to lend me his battery to see if that solves the problem, otherwise I'll try to revert to stock kernel – user61551 May 28 '14 at 16:05

protected by Community May 22 '15 at 18:56

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.