I have a Nexus 4 with CM (latest version). For the last few months whenever I dial a number it takes anywhere from 5-10 seconds for the actual call to start.

I checked Android SE and didn't find anything except for this: Dialer app becoming too slow and less responsive.

However, my case I believe is different. The question above asks about the actual dialer start-up time.

In my case, the dialer is very response: whenever I tap on the Phone icon in the tray, it shows up immediately (the stock Android dialer that comes with CM): I can switch between favourite contacts, recent contacts, search contacts and the dialer with no issues.

However, once I find the contact I need or dial the number and then tap to call, the screen goes black with a spinning wheel in the middle:

Spinning Wheel After Dialing a Number/Contact.
Spinning Wheel After Dialing a Number/Contact (click image for larger variant)

This takes about 5-10 seconds like I mentioned.

Once that time passes, it goes to the actual call where I can see the phone number, the contact picture (if available), the drop-call red button, etc.:

The Actual Call Screen after the Spinning Wheel
The Actual Call Screen after the Spinning Wheel (click image for larger variant)

What I've tried:

  1. Tried using a different dialer thinking maybe it's the issue with the stock dialer: no difference. Tried exDialer and some other, results are same: the dialer itself is snappy, but after tapping the call it goes to the spinning wheel on the black background.

  2. I don't think it's a memory issue as I have 2Gb I think. In any case, with all the text messages I have (I don't delete any), all the contacts I have (including hundreds of Google+ random dudes I follow), the Phone app itself is snappy: everything works very quick.

Any suggestions are welcome as it's getting very frustrating! Thanks

  • Could it be an issue with your provider? I'm not sure what's causing the delay here, and how exactly the dialer apps deal with it; but it might be the "spinning wheel" is shown while waiting for some response from the network. Could you try your SIM with a different device, to at least make sure whether the issue is bound to the device or not?
    – Izzy
    May 27, 2014 at 6:11
  • Are you using LTE? If so, the delay might be caused by Circuit-Switched Fallback (CSFB), which has to drop the network to 3G before making the call. May 27, 2014 at 8:07
  • @Izzy, I'll try a different phone, thanks for the suggestion. I hope it's not network related though!
    – ulmas
    May 27, 2014 at 13:48
  • @onik, I'm not on LTE. My network is actually WIND Mobile in Canada if that helps as additional info.
    – ulmas
    May 27, 2014 at 13:50

3 Answers 3


I had the same issue. So, after a lot of work and tests, I've discovered that what was causing the issue was the Prey app. Do you have the Pray app (or similar) installed on your device, perhaps?

After I've removed it, the dialer came back to work normally.

Hope it helps.

  • 3
    I didn't have Pray, but I had a couple of other apps for tracking calls: Call Log Monitor and Call Control. When I uninstalled them, the issue went away. When I re-installed the apps, they didn't cause the issue anymore. Thanks for the help.
    – ulmas
    Jun 18, 2014 at 16:58

Do you know how you spend hours trying to find a fix and you end up reading the most ridiculous suggestions and you think what an idiot, that can't possibly work...

Well here's one that worked for me: Settings → Backup & reset → Network settings reset

Fixed it! Dials within 2 secs now!


I Uninstalled linkedin and problem went away.

  • 2
    Welcome to Android Enthusiasts. Please note that this is a Q&A site and is recommended to give an answer with technical reasoning and link to sources to back your claim.Personal experience might help but a reasoning behind the answer would be appreciated.See How to answer
    – Manu
    Oct 13, 2015 at 2:30
  • 4
    Tell us how LinkedIn is related to the issue in question and how did you realize that it was the issue, in technical and not opinionated terms?
    – Firelord
    Oct 13, 2015 at 3:16
  • 1
    Especially: What makes you think that app is causing the issue for the OP, who didn't even mention using it? If it's not installed, it cannot be uninstalled.
    – Izzy
    Nov 2, 2015 at 15:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .