I'm trying to open my picasa folders in the android gallery. When I press the Picasa button, I get this message:

your google account is not linked to Picasa Web Albums. Please add another Google account

I found this link from xda.
It starts with "can't find the app", and "can't sync" (problems I don't have) but then someone starts about the "not linked" problems. The tips I found where about removing accounts (for youtube, for htc sense, etc), but that didn't help.

I found a link to Why can't I Sync Picasa Web Albums? , but this is not the same question. The sync option is in the accounts menu, but I can't seem to get picasa in the gallery.

I can upload (via gallery -> share) to picasa. I can also make new directories etc. I just can't see my picasa in the gallery


  • HTC Desire Z
  • "standard" htc software: android 2.2.1 with HTC sense (1.82.405.1)
  • HTC hub has "sync" enabled
  • my Google account has the picasa-sync enabled

Does anyone have a clue about how to fix this?

5 Answers 5


This is a bit of a stab in the dark from stuff I've read, but here goes...

I believe that the uploading is done through the generic Android/Google/Picasa features but HTC have their own gallery app that relies on an additional plugin to display Picasa Web Albums.

Go to the HTC Hub app, settings -> sync and make sure you have the sync option checked for HTC Hub. If you don't have the latest version of the Picasa plugin then you should get a notification to download it, which might fix your issue.

If you do already have the latest plugin then double check under the Accounts settings that your Google account is set to sync with Picasa and that there isn't an additional sync option somewhere for the plugin itself.

  • Thanks for the answer! I'll add the information to the question. I do have HTC Hub sync enabled, and my google account does have the sync options. There is no additional sync option. So no sollution I'm affraid :(
    – Nanne
    Commented Mar 17, 2011 at 19:17

Ok, not a real final answer, but this is what happened. I had another problem with the gallery, described here: Not all images showing up in gallery

In following all the advice there I have

  • Removed data from "gallery" application in menu->settings->applications
  • Removed the .thumbnails directory from /DCIM
  • Removed data from gallery app again.
  • Shut down the phone and removed the battery.

I don't know if that fixed the showing-up problem, but now all of a sudden I can actually see my picasa folders..


I had the same problem after having updated my incredible S to Gingerbread. I do not know if it was some kind of luck, but the following fixed the problem:

  • uninstall the picasa plugin (go to HTC Hub/plugins)
  • parameters/applications/manage/Gallery -> force the gallery application to stop.
  • Go back to HTC Hub/plugins and install again the Picasa plugin.
  • parameters/accounts and sync/ your google account/ enable the picasa update, and update now.
  • wait until the end of the update, then go back to the gallery, the picasa plugin should now have linked your picasa account with your google account!

Hope this will work for you too!



The HTC Hub suggestion put me in the right direction. I enabled the plugin when I was not using Picasa Web. Since Google+ I do, but the plugin said my google account was not linked to picasa web. Uninstalling and reinstalling did the trick.


Go online and download the .apk for Gallery for 2.1 and install. Make sure you have nonmarket apps checked (under Settings -> Applications -> Development). After install go back and sync all Google accounts. You will have two galleries but the new one will be able to sync with picasa. Open it and you should see all your picasa stuff. It worked for me with HTC Wildfire.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .