5

I have a corporate sync account set up to sync my work calendar, contacts and email. I had some trouble setting it up, but once I got it set up it worked just fine for a couple of months. Then about a week ago it stopped sending emails. I can still receive emails. Also, the internet still works on the phone. Gmail still works. Sending and receiving calls and texts still works. But when I send an email it gets stuck in the outbox.

I have tried removing the corporate sync account and adding it back. I have tried restarting the phone multiple times and doing a manual refresh each time. I have tried various combinations of security settings (Use secure connection and Verify Certificate). Nothing helps.

I can't believe no one has asked this yet! Based on the forum posts I have read, it seems like a common problem. Is there some solution waiting in the wings?

[Droid 2 w/ Froyo]

3

The first thing I'd suspect is that a database used by the Email app is corrupted. To fix this, you need to go to Settings -> Applications -> Manage applications, find the Email app, and clear the data for it. (If you see anything like "Email Storage" be sure to clear the data for that as well). Then re-add your account and see if that helps.

If that doesn't work, I recommend asking your company's IT department if they have changed any settings for the Exchange server recently.

  • Indeed the IT department had changed the settings. – Stainsor Mar 29 '12 at 19:27
1

I was seeing the same problem items get stacked in the outbox when you either aren't connected to WIFI or don't have cell coverage. Once you have access to a WIFI network the outbox will not empty out or sync either on its own or by going to settings and accounts and synching all.

All I did was compose a new message and sent it -- and all of the messages in the outbox seem to follow. ;-) Sounds too simple to work, but try it.

1

Probably you are using Exchange 2003, though there are some reports these things happen also with Exchange 2007.

Try to edit the messages stuck in the outbox and remove the check from the checkbox "Include quoted text". It will then send your message.

In the future, when you answer messages, choose the option "respond inline", and then it won't happen.

0

Weird, I had this problem, tried to send a message with no signal and when I got signal back, I kept getting "unable to send mail". I moved the messages to another folder and re-sent them and they went. Looks like a bug with the client.

0

I went to Settings, Application Management then INBOX - I forced stop the application and rebooted the device. All 23 of the emails in the OUTBOX are now going thru.

(I was not in a position to delete the account as Mathew Read suggested as the corporate IT group was not available today and they must be contacted when setting up this application before it will work.)

0

I just had this issue and it turned out I was over-quota. I didn't notice at first because I was still able to send email from Thunderbird, but once I logged into OWA it told me I was being prevented from sending due to quota issues.

0

Just to add on to the answers already mentioned here. From personal experience, I can tell you that it often depends on the file type or size.

I once had a difficulty with a pdf file, which I then had to convert and send as an image.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.